Support » How-To and Troubleshooting » [Resolved] You do not have sufficient permissions to access this page.

[Resolved] You do not have sufficient permissions to access this page.

  • I found another topic about this here but after I did all it said I didnt manage to solve the problem. First I had instlled 2.0 wordpress … i have upgraded and it worked just fine.. everything was perfect..but i’ve made some mistakes…with the db..and i didnt had a backup.

    So i had to reinstall. I use plesk … so i’ve installed 2.0 again ….and now..even if i dont upgrade it sais i dont have permisions. After i force-upgrade … i have some options.. (to view my admin profile ..and edit it) ..but i dont have any other options. Even if I upgrade (withoud force-upgrade|) .. to 2.3 I still have the same problem. I’ve tried this like 3 times… same thing.

    i dont know what to do πŸ™ …can anybody help me?

Viewing 12 replies - 1 through 12 (of 12 total)
  • anyone? … who knows more? …

    I haven’t a clue but I’m having the same problem. Using forced-upgrade got me into the admin profile but I still can’t do anything else.

    My hosting provider did the initial installation for me. I was going to try reinstalling manually but if thats not working for you I’m reluctant to go through all of the hassle.

    I also use Plesk; I wonder if that means anything?

    first time i’ve installed it from plesk … it worked perfectly… for a long time. after that i have installed it again… and upgraded it… and since then it doesnt working anymore. even if i delete everything and i install (the 2.0v) from Plesk …still sais the same thing. I dont know why …and I dont know what to do. and i found LOTS of topics about this problem in here..but very few solved… why isnt anybody doing anything?

    1. I went download the force_upgrade.php from Mark
    (search google by keyword ‘force upgrade Mark’)
    but it only fixed one thing, now when I login I can see ‘my profile’ and edit it. before, i only see dashboard

    2. if you have the access of phpmyadmin, go check the table xx_usermeta, see if all uses there were changed to have same value ‘a:1:{s:10:”subscriber”;b:1;}’

    if you know your user id (u may need to check xx_users) to find your user id (by number)

    therefore you know where you are in xx_usermeta,

    well, just replace that ‘a:1:{s:10:”subscriber”;b:1;}’ by this.


    3. in the final, clear all browser’s cookie and re login, press f5 for many times (force refresh). i solve my problem by this way. (my domain provider upgraded their database therefore i got this problem)

    hey man.. that really worked πŸ˜€ thanks a lot πŸ™‚ … i was about to go for movable type …cause i didnt thought there would be anybody to help me solve that problem with wp πŸ˜› … thanks a lot again πŸ˜€

    no me funcionΓ³ πŸ™

    This worked for me after I had the same issue after an integration attempt with bbpress. Just make sure you don’t include the single quotations at the beginning and end of the string…

    ‘a:1:{s:13:”administrator”;b:1;}’ <–not this

    a:1:{s:13:”administrator”;b:1;} <–type exactly like this



    Sorry, what field does this string go in? Is it in the meta_key, or the meta_value field?

    I had exactly this problem with a clean install of 2.6.2, which must’ve hung halfway through. I reinstalled and had the same problem again.

    Eventually I tried the force-update script from Mark which fixed the problem, despite this not being an upgrade.

    Thank you, bbodine1! That string in the usermeta fixed me right up. (I had tried the force-update with no success.)

    Thanks again!

    Way cool! Another upgrade problem solved.

    Used the force-upgrade then did the usermeta thing.

    Make sure that not only does it say administrator, but that is also says s:13.

    I know its a late reply but this worked for me: I tried everything, nothin worked, then went to phpmyadmin went to the wp_table then wp_user roles opened that up and compared it with my other working blogs found a difference changed it and it worked!!!! ok in the text on the second line it should be a:53: INSTEAD of a:51: simple now everything works!!!!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] You do not have sufficient permissions to access this page.’ is closed to new replies.