Support » Installing WordPress » You do not have sufficient permissions to access this page.

  • After getting this error message and not being able to solve the problem I decided to do a clean install of WordPress 3.0. The problem persisted so I contacted my webhost to ask them if they knew what could be wrong. They suggested me to try another clean install using a different database and so I did, but unfortunately that didn’t help either.

    – I’m using a clean install with the Twenty Ten 1.0 theme by the WordPress team
    – I tried resetting the plugins folder by FTP
    – I get the error while trying to switch to a different default header, an uploaded header and I’m sure I’d it with many other changes as well.

    I’m out of ideas. Could anyone please help me out with this?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Ok, for some still unkown reason I got it working. I looked into the source code of the wp-admin/themes.php?page=custom-headerpage and noticed the following on line 195:
    <input type="hidden" name="_wp_http_referer" value="/wp-admin/themes.php?page=custom-header?page=custom-header" />

    It says ?page=custom-header?page=custom-header twice. And when clicking the Save Changes button I noticed it added &step=1 to the end of the URL. So, I decided to manually edit the URL to end like this: wp-admin/themes.php?page=custom-header&step=1

    And for some reason everything suddenly works. I still don’t know what the problem was and why it suddenly works now, so I think there’s still something that needs to be fixed to prevent this from happening.

    Ideas anyone?

    Dint, could you explain me in short passages how to fix this?
    I’m stuck without being able to resolve anything. I have the same error in buddypress, but looking at the page source doesn’t help me nor hanging around the folders

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘You do not have sufficient permissions to access this page.’ is closed to new replies.