WordPress.org

Support

Support » Plugins and Hacks » [Resolved] You do not have sufficient permissions to access this page

[Resolved] You do not have sufficient permissions to access this page

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author StatCounterSupport
    Member

    @statcountersupport

    Are you logging with admin username or a as a sub-user ?

    This error should go away if you login using admin username. If this doesn’t fix the issue please feel free to email us at support (@) statcounter . com and we would be happy to assist you.

    I had the same problem. The stat counter support people suggested hard-coding the stat counter code into the site. This would probably work but is certainly not an elegant solution.

    I changed line 114 from
    <form method="post" action="options-general.php?page=StatCounter-Wordpress-Plugin.php">
    to
    <form method="post" action="">
    and it seems to have worked and applied the stat counter code to the footer … yet to see any reported stats though! 🙂

    doctordri
    Member

    @doctordri

    Same problem here. Into what file should those lines be hard-coded?

    charleme2004
    Member

    @charleme2004

    I had the same issue, plus the editor under the appearance tab was not showing up either, those two separate issues seem to be related in my case. The solution ended up being this:

    Check your wp-config.php in the root of your site, and make sure you don’t have something like define(‘DISALLOW_FILE_EDIT’, true);

    If you do have it, then all you need do is replace true with false. Simple, let me know if that works for you.

    GoScoutUK
    Member

    @goscoutuk

    I’ve had this too over multiple sites. The option to edit the settings disappears from the settings box in the menu.
    Making the change suggested above works. It puts back the option to insert the settings and gives me permission.

    This appears to be related to the upgrade to WP 4.0. Surely this should become a plugin upgrade, rather than have to edit files manually??

    GoScoutUK
    Member

    @goscoutuk

    Correction to my post above. It’s not a solution. I have iThemes security – what DOES work is unchecking the option in iThemes Security saying “File Editor Disable File Editor”
    That gives me back the permissions. When it’s re-checked, even with the mod above, the ability to access the settings page goes.

    Same problem here, I don’t have iThemes security so there’s nothing to check or uncheck.
    Any other suggestions?

    Plugin Author StatCounterSupport
    Member

    @statcountersupport

    We’re unable to recreate this issue on WordPress 4.0 with the latest version of the plugin. If you are still having trouble can you give us temporary access to your server to allow us to debug the issue.

    Please contact us at support AT statcounter DOT com

    We are also having the same problem using WordPress 4.0. Any attempt to update statcounter options results in following error:
    You do not have sufficient permissions to access this page.

    Plugin Author StatCounterSupport
    Member

    @statcountersupport

    We are still unable to recreate this issue. If any member is still having trouble then please send us a username and password for a wordpress log in where we can recreate the issue.

    The address to send to is support AT statcounter DOT com

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] You do not have sufficient permissions to access this page’ is closed to new replies.