The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

You do not have sufficient permissions to access this page. (5 posts)

  1. foreststation
    Posted 3 years ago #

    Using GoDaddy as host, I installed WP through the host. I renamed database tables using lower case characters only. I had created my Admin user name and password via GoDaddy's interface. When I go to the site it says "Welcome _username_" in the upper righthand corner, but when I try to log in with password I created, I get the "you do not have sufficient permissions to access this page." Troubleshooting:

    1) The DB prefix (all lower case) in wp-config matches the table prefixes in phpMyAdmin
    2) Meta value in phpMyAdmin is set to a:1:{s:13:"administrator";s:1:"1";}
    3) User level is set to 10

    Since it gives me that particular error, it seems I don't have permissions set correctly somewhere. On GoDaddy's interface, I'm not clear as to which files should be set in wp-admin to Web User Permissions read/write/execute and which should be Owner Permissions read/write/execute. Wondering if that's the culprit.

    Thank you for any help you can provide!

  2. Keith Driscoll
    Posted 3 years ago #

    I don't think file permissions are the problem. I think something is screwed up in the DB. Personally I would recommend a good security plugin such as Better WP Security. After all, why re-invent the wheel when something like changing the table prefix can be done with one click along with a host of other security specific tweaks available with the plugin I mentioned.

    You also need to search for fields in the options table that may still have 'wp_' as the prefix :)

  3. foreststation
    Posted 3 years ago #

    That would be great to be able to use the plugin, if I could log in to install it.

    And forgive my ignorance, but where is the Options Table? I updated the prefixes in phpMyAdmin.

  4. esmi
    Forum Moderator
    Posted 3 years ago #

    Try deleting the install and re-installing WordPress using a fresh download and a fresh database.

  5. foreststation
    Posted 3 years ago #

    That would probably be the best use of time at this point, esmi. Thank you.

Topic Closed

This topic has been closed to new replies.

About this Topic