[resolved] You do not have sufficient permissions to access this page (4 posts)

  1. TCS_NYC
    Posted 3 years ago #

    Good day all!

    I have recently been receiving the above error message upon logging into the admin section on my site (thechocolateswirl.com). I have followed all of the steps in the "Login Trouble" section of the forums/documentation without success (though my site now doesn't appear in any of my browsers, but as it was broken before when I renamed the plugin folder, this will be easy to fix once I get access to the admin section again).

    I have also tried deleting all of the files associated with the W3 Total Cache plugin, as that was the most recent change that I made to the site prior to being unable to access it.

    I get the error after logging in and being directed to .../wp-admin/profile.php. Attempting to access any other page in the admin section (manually) gets me the "cheatin' uh?" error

    I am currently running a linux server with the following settings:
    Apache version 2.2.23
    PHP version 5.3.18
    MySQL version 5.5.27-cll

    Please let me know if there is any other information I can provide. Thanks! :-)

  2. TCS_NYC
    Posted 3 years ago #

    Hey all! So I finally resolved my issue, without having to completely reinstall my site, plugins and such (well, I did that as part of the troubleshooting, but I'm hoping this resolution will help at least a few people to avoid all of that trouble).

    The problem was, apparently, that one of my plugins had corrupted the user roles definitions stored in the wp database. The table is wp_options (where "wp_" matches your table prefix) and the field to search for is wp_user_roles (again, "wp_" should be changed to your table prefix).

    The default roles are here: wp_user_roles. This link is from 12/2011, so if someone has a more recent link, or better yet a link to the wordpress codex that houses this information, please provide it here to help out others.

    I simply had to copy and paste the values in the above link into the corresponding field in my wp_options table, and I was able to login again.

    Please post if anyone else finds this useful, or if someone has any other suggestions for people facing this issue.

    Hope this helps! :-)

  3. Lovemonk
    Posted 3 years ago #

    This really helped me just now. Thanks for posting, thought you would like to know. :)

  4. dwb325
    Posted 2 years ago #

    I've been trying to fix this issue for a long long time and this is the post that solved it for me.

    I think the "All-in-One" events plug in corrupted my wp_user_roles.

    Thanks so much.

Topic Closed

This topic has been closed to new replies.

About this Topic