WordPress.org

Forums

iThemes Security (formerly Better WP Security)
You do not have sufficient permissions to access this page. (10 posts)

  1. wedmonds
    Member
    Posted 2 years ago #

    Hi Chaps,

    Novice user here.
    Website became hacked so deleting all files and re-installed from a backup dating back months. All came back up no problem.
    Installed better wp security having brought all my files up to date and no matter what I do, i constantly receive :

    You do not have sufficient permissions to access this page.

    Whenever I access any of the tabs or settings.
    Tried with 3 admin logins but still the same.

    Any ideas?

    http://wordpress.org/extend/plugins/better-wp-security/

  2. wedmonds
    Member
    Posted 2 years ago #

    bump

  3. Michael
    Member
    Posted 2 years ago #

    bump

  4. IAmNickOrtiz
    Member
    Posted 2 years ago #

    If you haven't already solved this issue. Is your login page redirecting you from /wp-admin/ to /login?

  5. ShawnRisk
    Member
    Posted 2 years ago #

    Nick: I have this exact problem and I am doing redirecting from /wp-admin/ to /login.

    Is there any solution to this problem?

  6. bobham
    Member
    Posted 2 years ago #

    This seems to only happen when using the page menu. If the left navigation is used, then everything works fine, I think.

  7. maridag
    Member
    Posted 2 years ago #

    I have exactly the same problem, with the added complication that I am using a theme from Clickbump - and this plugin hides the Clickbank icon in the WP dashboard, so that it cannot be accessed/modified.
    Deactivating the plugin restores the icon to the WP dashboard, so there is little doubt where the problem lies.
    I'm using the latest version of the plugin 3.4.6 - which I have now deactivated.

  8. CPilko
    Member
    Posted 2 years ago #

    I spent a few hours on Saturday cleaning up this problem on one of my multisite installations. I still haven't tracked down the culprit.

    My issue was the [WPDB_PREFIX]_[SITENO]_user_roles database entry in the [WPDB_PREFIX]_[SITENO]_options table was nearly empty. In the options table, there was a wp_[SITENO]_user_roles entry. I was able to copy this entry using phpMyAdmin into the correct field and it resolved my problems.

  9. YossarianC
    Member
    Posted 2 years ago #

    [OPEN]
    wp-config.php

    [FIND]
    define( 'DISALLOW_FILE_EDIT', true );

    [REPLACE]
    #define( 'DISALLOW_FILE_EDIT', true );

  10. evimakeup
    Member
    Posted 1 year ago #

    I have the same "You do not have sufficient permissions to access this page" problem, but the differences are:
    1. I can't even log in to the dashboard
    2. I could login normally yesterday

    The only thing I could try is erasing the "wp better security" (that seems to have caused this issue to many others) via my ftp, but still nothing.
    I tried to do the chance YossarianC suggested, but my ftp won't let me save or replace my wp-conflig.php file.
    Could anyone help???

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.