WordPress.org

Support

Support » Installation » [Resolved] “You do not have sufficient permissions to access this page.”

[Resolved] “You do not have sufficient permissions to access this page.”

  • Looks like something went wrong during my upgrade to 2.0. My site is still up, but I can’t get to the admin section at all.

    I get this message then I try to log in with a valid account, even with the admin account:

    “You do not have sufficient permissions to access this page.”

    There were some errors on the upgrade where the table “usermeta” was not created. I’m not sure if I can manually put this in or what, but out of 3 blogs that I’ve upgraded to 2.0 so far, this one is the only one that gave me trouble.

    The only thing that I can think of that makes this one different is that it is in a database that includes 2 more WordPress blogs. Not sure if that would make a difference.

    Not sure it helps, but the blog is here: http://www.joepopp.com

    Thanks,

    -spack

Viewing 15 replies - 46 through 60 (of 93 total)
  • To sum up this problem, because it looks like no one has, this is what works (a cocktail of fixes provided in this thread). If you’ve upgraded to WP2 using the upgrade.php and are getting the message “You do not have sufficient permissions to acces this page” when accessing the dashboard, do the following:

    Step 1
    Log out of wordpress if you have not already. You should not be signed in.

    Step 2 (from Ghacks)
    *Note: Select INSERT only if the upgrade process did not create the rows. In my case, the upgrade did insert the rows, but inserted / kepted the wrong information at which I had to correct the entry from data from another install and not INSERT a new row. There are a few tweaks to Ghacks attempt.

    Start Phpmyadmin
    Select wp_usermeta table
    Select BROWSE

    Select INSERT*
    user_id = 1
    meta_key = b2capabilities
    meta_value = a:1:{s:13:”administrator”;b:1;}

    SAVE

    Select INSERT*
    leave all as is except:
    user_id = 1
    meta_key = wp_user_level
    meta_value = 10

    SAVE

    Select wp_options table
    Select BROWSE

    Select INSERT*
    leave all as is except:
    user_id = 1
    meta_key = wp_capabilities
    meta_value = a:5:{s:13:”administrator”;a:2:{s:4:”name”;s:13:”Administrator”;s:12:”capabilities”;a:30:{s:13:”switch_themes”;b:1;s:11:”edit_themes”;b:1;s:16:”activate_plugins”;b:1;s:12:”edit_plugins”;b:1;s:10:”edit_users”;b:1;s:10:”edit_files”;b:1;s:14:”manage_options”;b:1;s:17:”moderate_comments”;b:1;s:17:”manage_categories”;b:1;s:12:”manage_links”;b:1;s:12:”upload_files”;b:1;s:6:”import”;b:1;s:15:”unfiltered_html”;b:1;s:10:”edit_posts”;b:1;s:17:”edit_others_posts”;b:1;s:20:”edit_published_posts”;b:1;s:13:”publish_posts”;b:1;s:10:”edit_pages”;b:1;s:4:”read”;b:1;s:8:”level_10″;b:1;s:7:”level_9″;b:1;s:7:”level_8″;b:1;s:7:”level_7″;b:1;s:7:”level_6″;b:1;s:7:”level_5″;b:1;s:7:”level_4″;b:1;s:7:”level_3″;b:1;s:7:”level_2″;b:1;s:7:”level_1″;b:1;s:7:”level_0″;b:1;}}s:6:”editor”;a:2:{s:4:”name”;s:6:”Editor”;s:12:”capabilities”;a:19:{s:17:”moderate_comments”;b:1;s:17:”manage_categories”;b:1;s:12:”manage_links”;b:1;s:12:”upload_files”;b:1;s:15:”unfiltered_html”;b:1;s:10:”edit_posts”;b:1;s:17:”edit_others_posts”;b:1;s:20:”edit_published_posts”;b:1;s:13:”publish_posts”;b:1;s:10:”edit_pages”;b:1;s:4:”read”;b:1;s:7:”level_7″;b:1;s:7:”level_6″;b:1;s:7:”level_5″;b:1;s:7:”level_4″;b:1;s:7:”level_3″;b:1;s:7:”level_2″;b:1;s:7:”level_1″;b:1;s:7:”level_0″;b:1;}}s:6:”author”;a:2:{s:4:”name”;s:6:”Author”;s:12:”capabilities”;a:8:{s:12:”upload_files”;b:1;s:10:”edit_posts”;b:1;s:20:”edit_published_posts”;b:1;s:13:”publish_posts”;b:1;s:4:”read”;b:1;s:7:”level_2″;b:1;s:7:”level_1″;b:1;s:7:”level_0″;b:1;}}s:11:”contributor”;a:2:{s:4:”name”;s:11:”Contributor”;s:12:”capabilities”;a:4:{s:10:”edit_posts”;b:1;s:4:”read”;b:1;s:7:”level_1″;b:1;s:7:”level_0″;b:1;}}s:10:”subscriber”;a:2:{s:4:”name”;s:10:”Subscriber”;s:12:”capabilities”;a:2:{s:4:”read”;b:1;s:7:”level_0″;b:1;}}}

    SAVE

    Step 3 (by wangxiaohu)
    In your ftp client or web development software, delete the “cache” folder located in the wp-content folder off the main directory. When you sign back in, WP2 will create a new cache folder with all the latest information from the changes made in Step 2. If you do not sign out (as recommended in Step 1), you risk keeping some of the same cache from that sign in and thus you will continue to get the problem.

    Step 4
    Now sign back into WP2. You should now be able to avoid the message and sign into the dashboard. Be sure to signout of your DB as well.

    Hope this will save someone 8 hours of pain.

    Hello everyone. I too had this same problem
    I did a clean install and then got the message that I did have sufficient permissions so I

    1. hand typed in the direct URL (not a virutal one) to the upgrade.php.
    is

    DOMAIN.COM/home/username/public_html/VIRUALBLOGDOMAIN/wp-admin/upgrade.php

    2. this caused me to have a blank page so I typed the direct URL again to domain.com/home/username/publichtml/blogURL/wp-admin
    at which point i got the main dash. and then everything worked

    Hi,

    On a new install, I was getting the sufficient permissions error.

    I edit my .htaccess file to read:

    php_flag magic_quotes_gpc off
    php_flag magic_quotes_runtime off

    Then upon saving that, problem went away. All is well now.

    Thanks to everyone for persisting on this.

    Chris

    Hello
    I just want to change some permissions because my friends – my weblog has 9 authors – can’t split (with “more tag”) their posts. I don’t want to change their rigths, they don’t need to edit all the other posts. They are “authors”, not “editors”, but can’t split your own posts. What I need to do?
    Thank’s
    Yuri
    _____
    http://blog.karaloka.net

    What the problem is that WordPress sets up _base_ structure when first installing. Without doing a install.php you wont create these base files.

    So empty you database in mysql, then create a black one of the same name and install.php. Then write back you main data base so it goes over the top then recove your admin password if different.

    If you don’t want this problem to happen again, you make sure when backing up your schema’s that to check the wp_usermeta is included as it may not, or else you will eb forced to do a cleared install each time you want to redo the project.

    Help.

    I don’t understand the instructions.

    Can someone give instructions for a complete newbie who upgraded and now just gets “insufficient” errors with every single move.

    Thank you in advance.

    Finally, a fix that worked for me :
    1. Renamed (disabled) the plugins-folder, just to be sure
    2. I use a working local copy of my WordPress install,
    so I was ablt to logon, and create a new user , make him admin
    3. Export the wp_usermeta (was somehow not created by the update-process) into sql
    4. Switch to my live database and import said SQL file containing the wp_usermeta-table.
    5.looking good…

    I tried to ugrade to 2.0.1 and forgot to disable all the plug-ins…I back tracked disabled, but I get the same issue as well, “don’t have sufficient premissions”. Am I stuck with 2.0 till 2.0.2? Thanks.

    I’m having this problem too, just did a simple upgrade from 2.0 and disabled all the plugins first. Please help!!

    I just reinstalled wordpress and it worked fine. If you check the dashboard it still thinks its on 2.0 if thats the case just re-upload the files and run the upgrade script.

    Voila! Solved it for me!

    Done that 3-4 times….no luck..

    I had this problem (on WP 2.01) after changing my database prefix from ‘wp_’ to something else. In addition to renaming all of my tables, I had to update entries in both the usermeta and options tables. Here are the statements, assuming that I’ve changed the table prefix from ‘wp_’ to ‘x_’.

    mysql> update x_options set option_name = 'x_user_roles' where option_name = 'wp_user_roles';
    Query OK, 1 row affected (0.00 sec)

    mysql> update x_usermeta set meta_key = 'x_capabilities' where meta_key = 'wp_capabilities';
    Query OK, 2 rows affected (0.25 sec)

    mysql> update x_usermeta set meta_key = 'x_user_level' where meta_key = 'wp_user_level';
    Query OK, 2 rows affected (0.00 sec)

    that works perfect.

    if somebody don’t understand what happened or how the fix works, msg me, i can explain. or contact me at irc nick: X7C server: irc.cl

    Maybe it’s me, but I wouldn’t call this issue resolved. Something is happening during the update process that really borks things up.

    I had the same issue, where, for some reason, my normal username/password for mysql didn’t work, i.e. when I hit the upgrade.php page, I got a slew of error messages stating that I couldn’t connect. So, I switched the login to the root login and the update worked. Strangely, I could log into mysql via the command line using the “bad” account without any problems.

    Also, there isn’t one definitive FIX for this issue. I used ghacks fix, switching the wp_capabilities value to {a:1:{s:13:”administrator”;b:1;}. There are a few misleading posts here as well. Do I need to make the changes to .htaccess? Who knows. No one has said if that’s necessary. And is the large entry mentioned by brunovernay for wp_capabilities necessary? Using only “{a:1:{s:13:”administrator”;b:1;}”, I’m not seeing any further problems.

    And finally, artisan949 mentions using this in the wp_options table, which has to be wrong as the field names do not match.

Viewing 15 replies - 46 through 60 (of 93 total)
  • The topic ‘[Resolved] “You do not have sufficient permissions to access this page.”’ is closed to new replies.
Skip to toolbar