Support » Installing WordPress » “You do not have sufficient permissions to access this page.”

  • Resolved spackletoe


    Looks like something went wrong during my upgrade to 2.0. My site is still up, but I can’t get to the admin section at all.

    I get this message then I try to log in with a valid account, even with the admin account:

    “You do not have sufficient permissions to access this page.”

    There were some errors on the upgrade where the table “usermeta” was not created. I’m not sure if I can manually put this in or what, but out of 3 blogs that I’ve upgraded to 2.0 so far, this one is the only one that gave me trouble.

    The only thing that I can think of that makes this one different is that it is in a database that includes 2 more WordPress blogs. Not sure if that would make a difference.

    Not sure it helps, but the blog is here:



Viewing 15 replies - 31 through 45 (of 93 total)
  • Ghacks, you’re the best ! It works ! Now, I have to figure out if I dare make the upgrade of my real blog or if I am definitely too sacry of loosing my datas… 😉

    Koztoujours I tried it with one of my smaller blogs, only admin and only 4 posts 😛

    I won´t try it on one of my big ones, to risky atm for me..

    Same as you : I did it on a small small blog…

    Sorry, but it seems that the problem occurs again…
    A little bit upsetting.

    i presume people are having the same problem as me, so ill give a detailed run through maybee it will shed some light on whats happening…

    when i loaded the upgrade page ( upgrading from 1.5.1 ) i initially had a lot of errors (about 15 or so ) along the lines of :

    WordPress database error: [Table ‘database.wp_usermeta’ doesn’t exist]

    so i ran the upgrade.php again and got no errors.

    the site front end works and i can login to the adminbut when i goto profile / logout / add post etc.etc. i get the ‘you do not have sufficient permissions to access this page’ and the top nav pane is missing.

    logging into the dbase i cannot see the wp_usermeta table so i presume this is why I and many others are having this problem….

    as a workaround maybee some kind person could post the raw SQL update script i can run on the database ?

    I ran into the same problem, fortunately in a test environment. In my case I was able to determine that the problem was caused by the security configuration I use.

    Normally, my wp-config.php database user is a limited user that doesn’t have rights to create tables. I mistakenly ran the update.php script with that user still enabled, and apparently, while part of the script failed, part of the script succeeded. Thus, when I re-ran it with the “dba” user enabled, it didn’t do everything it needed to do.

    I found a fix that worked, at least on my system, which was to drop the database, reload it from the just-before-upgrade backup and re-run the update.php script using the “dba” user.

    Hopefully: (1) I won’t have the same problem on my live site, and (2) this information is useful, either to users with the same problem, or to someone trying to produce a general fix.

    I don’t remeber whether I had my blog opened anywhere when I initiated the upgrade … I will try the solution you give but it would be great if there could a safe upgrade process.

    To the support team : I know that week has certainly be harassing, but, please consider re-labelling this thread as NOT RESOLVED. This is a major problem as it prevents numerous would-be users from administrating their blog and it is NOT resolved. Thank you.

    Each morning, I come to this page, with the hope that during your turn to be awake, (you, in the US), an answer would have been given to this problem which impede me (and other wordpress users : eg from upgrading and using 2.0…

    I don’t understand the silence of the team on that issue. My situation is not unique, the problem is quite a major one and it is clear that upgrading in such a case is out of question.

    This topic is labelle as resolved. If this is the case and I am too stupid to see the solution given, please be kind enough to tell me. But do not remain that silent….

    I am hosted on too and I succed to connect :

    • as “ghacks” suggested I changed “wp_capabilities” to a:5:{s:13:”administrator”;a:2:{s:4:”name”;s:13:”Administrator”;s:12:”capabilities”;a:30:{s:13:”switch_themes”;b:1;s:11:”edit_themes”;b:1;s:16:”activate_plugins”;b:1;s:12:”edit_plugins”;b:1;s:10:”edit_users”;b:1;s:10:”edit_files”;b:1;s:14:”manage_options”;b:1;s:17:”moderate_comments”;b:1;s:17:”manage_categories”;b:1;s:12:”manage_links”;b:1;s:12:”upload_files”;b:1;s:6:”import”;b:1;s:15:”unfiltered_html”;b:1;s:10:”edit_posts”;b:1;s:17:”edit_others_posts”;b:1;s:20:”edit_published_posts”;b:1;s:13:”publish_posts”;b:1;s:10:”edit_pages”;b:1;s:4:”read”;b:1;s:8:”level_10″;b:1;s:7:”level_9″;b:1;s:7:”level_8″;b:1;s:7:”level_7″;b:1;s:7:”level_6″;b:1;s:7:”level_5″;b:1;s:7:”level_4″;b:1;s:7:”level_3″;b:1;s:7:”level_2″;b:1;s:7:”level_1″;b:1;s:7:”level_0″;b:1;}}s:6:”editor”;a:2:{s:4:”name”;s:6:”Editor”;s:12:”capabilities”;a:19:{s:17:”moderate_comments”;b:1;s:17:”manage_categories”;b:1;s:12:”manage_links”;b:1;s:12:”upload_files”;b:1;s:15:”unfiltered_html”;b:1;s:10:”edit_posts”;b:1;s:17:”edit_others_posts”;b:1;s:20:”edit_published_posts”;b:1;s:13:”publish_posts”;b:1;s:10:”edit_pages”;b:1;s:4:”read”;b:1;s:7:”level_7″;b:1;s:7:”level_6″;b:1;s:7:”level_5″;b:1;s:7:”level_4″;b:1;s:7:”level_3″;b:1;s:7:”level_2″;b:1;s:7:”level_1″;b:1;s:7:”level_0″;b:1;}}s:6:”author”;a:2:{s:4:”name”;s:6:”Author”;s:12:”capabilities”;a:8:{s:12:”upload_files”;b:1;s:10:”edit_posts”;b:1;s:20:”edit_published_posts”;b:1;s:13:”publish_posts”;b:1;s:4:”read”;b:1;s:7:”level_2″;b:1;s:7:”level_1″;b:1;s:7:”level_0″;b:1;}}s:11:”contributor”;a:2:{s:4:”name”;s:11:”Contributor”;s:12:”capabilities”;a:4:{s:10:”edit_posts”;b:1;s:4:”read”;b:1;s:7:”level_1″;b:1;s:7:”level_0″;b:1;}}s:10:”subscriber”;a:2:{s:4:”name”;s:10:”Subscriber”;s:12:”capabilities”;a:2:{s:4:”read”;b:1;s:7:”level_0″;b:1;}}} (it may not be optimal, but it worked)
    • Deleted the “cache”
    • deleted the cookies (not sure if it is really usefull)
    • reconnect.

    Did you try this ?

    Not sure if this is the same issue, but here’s my problem:

    The install went fine, I could log in and access the admin area. However, very quickly, I got a 403 Forbidden Error. I discovered that if I deleted teh dbx-postmeta cookie, everything went back to normal, until that cookie is recreated in the post.php and edit.php pages. Every time, I delete that cookie and everything works again, I can access the Presentation, Users, Plugins, Manage, Dashboard links, but as soon as I click Write or Edit, I keep getting the 403 “Forbidden – You don’t have permission to access /wp-admin/edit.php on this server” error.

    The cookie isn’t created when I disable Javascript. In addition, the page loads correctly when it’s disabled and does load properly when it IS enabled.

    I’m also having this problem. I just went straight into upgrading as well, so as it stands I can’t administer my blog!

    “The cookie isn’t created when I disable Javascript. In addition, the page loads correctly when it’s disabled and does load properly when it IS enabled.”

    Sorry I meant that it does NOT load properly when JS is enabled.

    I ran into the same problem with one of my WordPress setups. None of the other solutions worked, but here’s what worked for me; maybe it will help someone else:

    In wp-config.php you can set the table prefixes to whatever you want. For this example, I’m pretending that I’ve set $table_prefix to ‘wp_whatever_’.

    In the “usermeta” table, “wp_whatever_usermeta,” there were settings for “wp_user_level” and “wp_capabilities”; However these should have said wp_whatever_user_level” and “wp_whatever_capabilities” respectively.

    Likewise, in the options table, “wp_whatever_options”, there was an option for “wp_user_roles” that should have said “wp_whatever_user_roles”.

    Changing those settings fixed the problem for me.

    I ran into both the 403 Forbidden error and the one included as the topic of this post. The 403 error I fixed by adding the line:

    DirectoryIndex index.html index.php

    Witihin the VirtualHost defined in my local.conf (a.k.a httpd.conf) file for Apache. W/o it Apache didn’t know to open up /wp-admin/index.php when wp-login.php redirected to /wp-admin/ upon logging in as the administrator.

    I fixed the “You do not have sufficient permissions to access this page.” error by changing the following line in my PHP.ini:

    magic_quotes_runtime = Off

    It was set to “On”, and was therefore escaping quotes from data taken from the database. The code for wordpress can probably be changed so this directive can remain “On” if you’d rather be more secure, I suppose. That’s just a hunch.

    Anyways, these two small changes worked for me. Just thought I’d share.

Viewing 15 replies - 31 through 45 (of 93 total)
  • The topic ‘“You do not have sufficient permissions to access this page.”’ is closed to new replies.