Support » Installing WordPress » “You do not have sufficient permissions to access this page.”

  • Resolved spackletoe

    (@spackletoe)


    Looks like something went wrong during my upgrade to 2.0. My site is still up, but I can’t get to the admin section at all.

    I get this message then I try to log in with a valid account, even with the admin account:

    “You do not have sufficient permissions to access this page.”

    There were some errors on the upgrade where the table “usermeta” was not created. I’m not sure if I can manually put this in or what, but out of 3 blogs that I’ve upgraded to 2.0 so far, this one is the only one that gave me trouble.

    The only thing that I can think of that makes this one different is that it is in a database that includes 2 more WordPress blogs. Not sure if that would make a difference.

    Not sure it helps, but the blog is here: http://www.joepopp.com

    Thanks,

    -spack

Viewing 15 replies - 16 through 30 (of 93 total)
  • Just a shot in the dark–also check that the wp_usermeta table record for your user_id with a meta_key of wp_user_level is set to 10.

    What all should be in usermeta?
    I have first_name, last_name, nickname, wp_user_level, and wp_capabilities

    MichaelH, I have that exactly, but for some reason it’s not recognizing it.

    phoenix, as far as I know, here’s that the usermeta table looks like:

    wp_usermeta table has the following fields:
    umeta_id
    user_id
    meta_key
    meta_value

    MY wp_usermeta table has the following rows (all with user_id field = 1):
    first_name (my first name)
    last_name (my last name)
    nickname (admin)
    wp_user_level (10)
    wp_capabilities (a:1:{s:13:”administrator”;b:1;})
    rich_editing (true)

    Now one thing that I have that may be unique is that I use a different prefix in my config file: “wp1_” but I wouldn’t think that would make much difference.

    Anyone else have anythign that’s workin that looks different from the above?

    As far as I am concerned, and to answer a previous question, I do not have any plugin as the blog that I upgraded was only a test one. I did not install any.

    I have the same problem after logged into the admin interface. Except Dashboard, all other links in admin interface give me “You do not have sufficient permissions to access this page.”

    It seems to be a bug with the cache on user capabilities.
    A workaround consists in commenting the following lines in wp-includes/pluggable-functions.php:

    // $user = wp_cache_get($user_id, ‘users’);
    //
    // if ( $user )
    // return $user;

    (37-41)

    I am now able to get rid of this problem by:

    1. Log out if you see “Log out” some where
    2. Remove /wp-content/cache completely
    3. Login again

    However, I found another problem that the reset password function is not working. I am still using the old password to login.

    It seems that the bug is related to the cache system of new WP2.

    I had noted that issue concerning the reste password functionality on RC3 …

    Just one thing : when you say “2. Remove /wp-content/cache completely”, could you explain “cache”. I am not english-speaking (as U may have noted) and I am not sure of what this means. I guess it’s not deleting the wp-content folder 😉 !

    Man, I hate to say it, but neither solution above worked. After commenting out those lines in pluggable-functions AND deleting my cache folder, I still get the “You do not have sufficient permissions to access this page.” upon login.

    It tries to take me immediately to profile.php, by the way. When I just try to go to the dashboard page, it lets me, but as before these fixes, there is no main navigation and any link I try tell me I don’t have permission to access it.

    Koztoujours: There’s a folder called “cache” in your wp-includes folder, he’s talking about deleting that.

    So outside of this being a full on 2.0 bug, how do we figure out what to do next? Was anyone able to verify my table/field information above?

    okay guys, I did a huge work-around. I created a new 2.0 install in the same database with a new prefix, then I renamed the posts, comments, categories, and a couple other tables in my 1.5 install’s DB to make them work in the new install. This required adding some fields to those tables, but it wasn’t too difficult.

    The only thing I can see that is weird is that the comment counts are all off. So the site says there are 0 comments in each post when there are actually more. Does anyone know how I could re-build the comment count? This is obviously something that gets done when the upgrade to 2.0 happens, but I can’t go back to that now, unfortunately.

    Thanks for all of your help!

    -spack

    Thank for your info, spackletoe, but, as U say, your work-around is huge !!! I don’t thiink I am going to upgrade my “real” blog until I have other clues to do it properly.

    Mhhhh…

    Add me to the list 🙁

    I used firefox to do the upgrade and it went wrong.
    I went back to explorer and did not get further error messages but still the infamous permissions message.

    I do have a wp_usemeta but with 0 record in it…

    Am I the only one ?

    Ralph

    Is there anybody up there who would feel like considering this issue ?

    Okay, looks like I found a way to fix it. I’m not a guru, so this might not be a clean way to make things work but it worked for me 😉

    I knew something was wrong with the wp_usemeta having 0 records. So I:

    – renamed the wordpress database
    – did a fresh install (not upgrade)
    – did an export of the wp_usermeta
    – dropped the new database
    – rename the old db back to wordpress
    – droppped the old wp_usermeta
    – imported the newer wp_usermeta

    it works… I assume I only have ‘admin’ as a user now, but I don’t think it will have any impact for me.

    Ralph

    i first thought it was a permission problem but the empty usermeta is the key.

    I edited the following entries to it and its working flawlessly now. This is only working if you have no users other than the admin, not sure how to add the users as well.

    Start Phpmyadmin
    Select wp_usermeta table
    Select INSERT
    leave all as is exept:

    user_id Value 1
    meta_key Value nickname
    meta_value admin

    SAVE

    Select INSERT
    leave all as is exept:
    user_id Value 1
    meta_key Value wp_user_level
    meta_value 10

    SAVE

    Select INSERT
    leave all as is exept:
    user_id Value 1
    meta_key Value wp_capabilities
    meta_value (look into wp_options table, select browse, row wp_user_roles, copy everything from values into meta_value)

    SAVE

    login, you can work with 2.0, no permission problem anymore

Viewing 15 replies - 16 through 30 (of 93 total)
  • The topic ‘“You do not have sufficient permissions to access this page.”’ is closed to new replies.