WordPress.org

Support

Support » Installation » [Resolved] “You do not have sufficient permissions to access this page.”

[Resolved] “You do not have sufficient permissions to access this page.”

  • spackletoe
    Participant

    @spackletoe

    Looks like something went wrong during my upgrade to 2.0. My site is still up, but I can’t get to the admin section at all.

    I get this message then I try to log in with a valid account, even with the admin account:

    “You do not have sufficient permissions to access this page.”

    There were some errors on the upgrade where the table “usermeta” was not created. I’m not sure if I can manually put this in or what, but out of 3 blogs that I’ve upgraded to 2.0 so far, this one is the only one that gave me trouble.

    The only thing that I can think of that makes this one different is that it is in a database that includes 2 more WordPress blogs. Not sure if that would make a difference.

    Not sure it helps, but the blog is here: http://www.joepopp.com

    Thanks,

    -spack

Viewing 15 replies - 1 through 15 (of 93 total)
  • I am getting a similar error, but slightly more specific.

    The upgrade seems to have worked fine with the exception that I cannot access post.php, even with an administrator account

    I have tried the following:

    1. Setting the permissions to “Editor” then back to “Administrator”.

    2. Create a brand new user set to administrator and then try to post new or edit.

    The error is simply a blank screen with “You do not have sufficient permissions to access this page.”

    Any help would be great, otherwise I’ll have to revert to 1.5.2

    I had this problem and I solved it by disabling all my plugins. As soon as I did that the permissions cleared right up. I am now going through my plugins one at a time until the error repeats itself.

    I would start there, very likely a conflict in that area.

    Just want to confirm ergate’s findings. Although I de-activated plugins prior tot he upgrade, I got this error when activating particular plugins. Hope this helps

    Thanks for the advice… My particular case was the LivePress plugin.. I guess I’ll have to search for a newer version or different plugin for synching with livejournal.

    You should report this to the LivePress guys so they can look into it as well.

    spackletoe
    Participant

    @spackletoe

    Thanks for the info guys, I’ve removed all of my plug-ins and I can log in now! BUT… There’s no navbar, and I get the “you don’t have permission” message when I try to go anywhere.

    I think this is because don’t have a usermeta table in my DB. The system doesn’t know what priviledges I have and so it doesn’t let me go to any pages within the admin section.

    Anyone know how I should go about manually addding the table and fields to the DB to get my access back? I’m going to try to attempt to do some myPHPAdmin surgery by duplicating info from another one of my successful 2.0 upgrades. Wish me luck, and any info is appreciated.

    Thanks,

    -spack

    I am not a WP expert, but I would probably make sure I have backups of all my db info, then do a complete fresh install, new tables etc. Then start importing the tables/data into the fresh db.

    Koztoujours
    Member

    @koztoujours

    Hello.

    I have tried the upgrade on a test blog (hopefully not the real one) and I have the same message, “You do not have sufficient permissions to access this page”, as soon as I try to use any admin igth, such as posting… as I am the only user of the blog.

    I have access to the admin page but it seems that I am not recognized as the admin.. Indeed, I cannot log in with my admin infos.

    Koztoujours
    Member

    @koztoujours

    I have tried to change the password manually in the SQL base. No changes.

    Did you check plugins as Previously mentioned in this thread?

    I am experiencing a similar problem as well. I can’t log in after I logged out (My blog has only one user, and that’s me). Whenever I try to get anywhere in wp-admin, the message appears.

    spackletoe
    Participant

    @spackletoe

    Well, I can’t seem to get anything to come up, even after tinkering with the tables in MyPHP. I don’t seem to have appropriate access to import stuff from another working database.

    Really frustrating. I’d love to hear from someone who knows that wordpress is expecting to find in the DB as far as user permission go.

    Starting over from a backup yields the same result as where I am now.

    Just a hunch!
    At upgrading, did you overwrite the wp-config.php, where the database name and user/pw resides. In that fatal event, restore the old config file.

    I am having the same problem. wp-config.php was not overwritten. Upload went fine.

    My capabilities is listed as
    a:1:{s:13:”administrator”;b:1;}
    in Usermeta.

    spackletoe
    Participant

    @spackletoe

    I can verify that a WORKING admin account has that same field and the same value in that field. But putting it in manually didn’t seem to do the trick.

    a:1:{s:13:”administrator”;b:1;}

    How can I turn on some sort of verbose mode that will tell me why certain errors are coming up? Is this possible?

Viewing 15 replies - 1 through 15 (of 93 total)
  • The topic ‘[Resolved] “You do not have sufficient permissions to access this page.”’ is closed to new replies.