You do not have sufficient permissions (8 posts)

  1. CreativeChick
    Posted 8 years ago #

    I just moved the entire blog to a new database after renaming the tables. Everything works, except for the fact that I cannot log in at all. I would like to know if reinstalling WP would help the problem, or would it just be easier for me to rebuild the blog...I only have 20 something posts. Everything else works great. I did go to this tutorial and I used this one as well. Everything is where it should be. I've tried F5 to refresh, I keep getting

    You do not have sufficient permissions to access this page.

    The blog is there, all the entries, comments, etc. I just cannot login at all. Any help would be great. I would love to get this sorted out and upgrade to the newest version. Thanks in advance.

  2. MichaelH
    Posted 8 years ago #

    Don't know if this is your problem but please note that some of the rows (records) in your usermeta table use the database prefix when composing the meta_key values for a user's capabilities and user_level.

  3. CreativeChick
    Posted 8 years ago #


    Thank you for your reply, where would I fix those rows?


  4. CreativeChick
    Posted 8 years ago #

    Anyone? How can I fix the rows? I don't know where to look. Thanks in advance. :)

  5. frawsty
    Posted 8 years ago #

    Hi did you ever figure this out? I just did after having the same problem.

    I had renamed all the wp tables in the database and updated the config.php. The blog continued to work normally until I tried to log in and kept getting:

    You do not have sufficient permissions to access this page.

    I have found out that just renaming the tables and updating the config wasn't enough. You have to update three records:

    go into your phpmyadmin to your _options table find record: wp_user_roles or xxx_user_roles and rename it to match your table prefix.

    Next go into your wp_usermeta or xxx_usermeta table find and edit: wp_capabilities, wp_autosave_draft_ids and wp_user_level
    and do the same thing, rename to match your table prefixes.

    Things should begin working for you after.

  6. drmiketemp
    Posted 8 years ago #

    Grab the script linked to in this post and try it:


    Hope this helps,

  7. CreativeChick
    Posted 8 years ago #

    Thanks for the reply. I ended up dumping it and starting fresh. There weren't many entries or comments to worry about.

  8. kayakbabe
    Posted 7 years ago #

    Your solution was the ticket for me.

    I copied my db tables and moved wordpress to a different website. I thought I had edited all the url references in the actual wordpress configs and also in the db tables. But I completely missed the prefixes on table field names in the xxx_options and xxx_usermeta tables.
    That completely fixed it!
    Thank you!

Topic Closed

This topic has been closed to new replies.

About this Topic