Support » Fixing WordPress » You do not have sufficient permission to do …..

  • adsismine


    I can not access to my blog.
    After i installed a plugin, wordpress gave the error ‘ you do not have sufficient permissions/access to do ….
    I can not log in at all.

    The same thing happenned to me 3 days before. I had to reinstall WP.
    I know many things about computers, internet..But I am not a developer or designer..just a user..and As i am not a heavy WP User it really take lots of efforts to try those solutions.

    I searched for the solutions. Lots of people offer different solutions..I do not understand most of them even.

    And i wonder if these kind of problems happen all the time, how people can use WordPress. And how WP can spread…

Viewing 4 replies - 1 through 4 (of 4 total)
  • mrmist


    See if this helps –

    Access your database via phpMyAdmin (most hosting providers offer this in their control panel), go to the wp_users table and find the row for your user_login . Note the ID of this row. Now, go to the wp_usermeta table and find the wp_capabilities row for your user_id . Set the value of this row to a:1:{s:13:”administrator”;b:1;}

    after 3.1 upgrade (manual) I get the same permission error 304

    but once I log out and log back in it

    a) I am able to make some change to plugin

    b) or (and more common) the change actually took affect once I click back from the error page to the plugin admin page.

    I noticed this as well when I did manual upgrade, as I turned off all plugins. After the upgrade and update of DB I checked all plugins to reactivate but I got the error.

    relogged back in and all the plugins were active



    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Ten theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    I have done every thing recommended above.

    I still get 403 permission error when activating or deactivating plugins.

    Running plain vanilla twentyten with wp-supercache and cdn sync tool. Same resultsa when on or off.

    I also have ongoing problem with autoupdate not working prior to 3.1 and continuing now where file never gets fully downloaded or unpacked as a tmp file is in wp-content later.

    The odd thing is this.

    My host is

    halfwaytoconcord is on one cpanel and two other wp installs are on another. They work fine and zip along with updates and regualr admin activations etc. Just the halfwaytoconcord site is noxious.

    What could I ask host or some het-admin to compare to better troubleshoot, as what I see you guys saying is that there may be something about the PHP install that is causing issues with WP?

    As ever, thanks for any clue.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘You do not have sufficient permission to do …..’ is closed to new replies.