WordPress.org

Support

Support » How-To and Troubleshooting » You do not have permission to preview drafts.

You do not have permission to preview drafts.

  • I’ve upgraded to 2.7 from 2.6.5. I am logged into my blog as admin. I click on “preview” to look at a already published post. The page appears with nothing but “You do not have permission to preview drafts.” Any halp would be greatly appreciated!

    Thanks,
    sprezzatura.rrd2 at yahoo dot com

Viewing 15 replies - 1 through 15 (of 26 total)
  • mrmist

    @mrmist

    Forum Janitor

    Hello

    New drafts or all drafts?
    Your own or other people’s?

    Not sure what you mean by “an already published post” – if it’s published then it wont be a draft any more, so you wouldn’t have the preview button.

    Can you explain the process you are going through in more detail?

    I am having the same issue – i type an article ( i am an admin ) You do not have permission to preview drafts. comes up on a new page in black text – thats it.

    I wonder – what are your setups – i.e. php, etc. I just previewed a published post and it doesn’t do that, it works just fine…

    Firefox Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

    No, I have not tried it in any other browsers.
    URL http://www.evolved.fm/2008/12/dubai-after-dark/?preview=true&preview_id=318&preview_nonce=aeba67d40d (if it works for you) that shows the You do not have permission etc..

    Sorry – I meant on your server where you have the software installed, not on your computer. What versions of PHP/MySQL do you have?

    Hi, I’m running 2.7, having upgraded a week ago. Today I tried to open a series of sub pages, six in all, from links on my main page but I get a blank page and the message, “You do not have permission to preview drafts.”

    These sub pages are not drafts. They have all been published in the past and are inaccessible as from today. I tested my site as a visitor, logging out of admin, and still the pages appeared as blanks. The title and comment boxes sections were visible at the top and tail of each page, but all the content that you’d see in the edit box was missing.

    I can still open the subpages in the dashboard editor, in visual and html view, and the material is there. However, they cannot be previewed or visited.

    Could it be that when I originally linked the pages, I linked the main page to the preview URLs? I can’t see that being a problem in that my sub pages only became blank today. Although my content exists in edit view, I don’t want to cut and paste it on to new pages and lose all my existing search links.

    The one thing I did today was load the Feedburner plugin for WordPress, which I’ve since disabled and can’t imagine that this is the problem.

    I wondered if there might be a hitch with page autosaves from the past replacing my saved material with a big nothing. Is the autosave function writing blank space over actual pages that still open but only in edit view? When I try to preview from the dashboard page/post editor, I also get a page devoid of content

    Any ideas?

    I really don’t understand what you mean by “linked the pages from the Preview URLs”.

    Ok, everything else aside, the main problem seems to be the Preview button generating this error: “You do not have permission to preview drafts.”

    I’m also experiencing the error when I click the Preview button on the Edit Post page. The button exists even when editing and trying to preview a new, unpublished post.

    I am running wp 2.7 on PHP 5.3.8 and MySQL 5.0.5.

    Could this be a directory permissions issue? Just spit balling here. Any thoughts would be appreciated.

    I had the same message this morning.
    Accidently I found a solution, or call it workaround, for this. Changing your Blog URL settings, or change them manually might do the trick.
    Anyway I See if this works

    Hi everyone, everyone here is using FireFox, correct?

    If so, that might be the problem. I use it too and I see the

    you do not have permission

    msg too

    It’s not a browser problem, I had the same trouble with FF and IE. As EdwinO said, the answer seems to be in the blog title. Make sure WordPress address (URL) and Blog address (URL) are the same (worked for me).

    I noticed this problem once I moved my WordPress installation to a sub directory. Wonder if that is affecting things.

    this works fine if wordpress address and blog address match.

    things don’t work if they do not match. i use a subdomain as the blog address, and the blog is in a subdirectory, and I can never preview anything. I always get the ‘ You do not have permission to preview drafts.’. this is on 2.7.1. I have another blog where everything is the same (PHP, linux, apached, wp2.7.1, and it works fine, and the wordpress and blog address match.

    Well then, the problem remains. I don’t see a reason why anyone should have to sacrifice the ability to preview their drafts if they want their WP installation to be in a subdirectory but keep their “clean” url.

    The capability to have your blog’s url be different from the directory where WP is installed has been supported in WP for ages, and this previewing glitch has only popped up since the advent of 2.7.1.

    I still therefore ask, what gives?

    yep – got the problem here as well

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘You do not have permission to preview drafts.’ is closed to new replies.