Support » Plugin: Breadcrumb NavXT » You do not have permission to access this page

  • kappesante

    (@kappekappesantecom)


    wp-admin/options-general.php?page=breadcrumb-navxt

    You do not have permission to access this page.

    what happens here?

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author John Havlik

    (@mtekk)

    So, it’s likely you don’t have bcn_manage_options capability for your user type (likely a non-administrator user). You’ll have to add that capability using something like get_role('USER_ROLE')->add_cap('bcn_manage_options'); within a filter hooked into the admin_init action.

    Confirming this issue on clean install with admin account (the only account on the website).

    Plugin Author John Havlik

    (@mtekk)

    @designlions If your user is of the administrator role, and/or has the bcn_manage_options capability, then the next most likely possibility is that you have some sort of WAF (web application firewall), such as ModSecurity or WordFence that doesn’t like something.

    Temporary fix via functions.php:

    function add_bcn_manage_options_to_admin() {
        // gets the administrator role
        $role = get_role( 'administrator' );
     
        // would allow the administrator to manage breadcrumbs. Fix needed due the conflict in Breadcrumb NavXT version 7 with some other plugin.
        $role->add_cap( 'bcn_manage_options' ); 
    }
    add_action( 'admin_init', 'add_bcn_manage_options_to_admin');

    Thank you @mtekk for the appropriate capability that needed to be added.

    Plugin Author John Havlik

    (@mtekk)

    @designlions so what is concerning is code almost exactly like this is already in Breadcrumb NavXT. So, for some reason it isn’t taking effect on your install. I’m going to have to think about this a little, at some point I may have a few things that I’d appreciate if you could test (to try to diagnose what is really going on).

    @mtekk sure thing. I would be glad to help you out.

    Same problem. @designlions Thanks for the fix.

    Hi! I have the same problem. Using the newest WordPress version 5.8.2. Just tried the given fix (tks) but to no avail…Back again: flushed my caches but still the same problem…

    • This reply was modified 11 months, 1 week ago by derek1957.
    • This reply was modified 11 months, 1 week ago by derek1957.

    I’ve the same issue with Versie 7.0.1, when i click on settings i get a error:

    Je hebt geen toestemming om deze pagina te bekijken.
    wp-admin/options-general.php?page=breadcrumb-navxt

    Plugin Author John Havlik

    (@mtekk)

    So, the confusing part of this is that on my testbed (WP 5.8.2, PHP8, Breadcrumb NavXT 7.0.1), the code that adds the bcn_manage_options capability is getting called (on every admin page), so simply visiting the dashboard should get that capability added to the administrator role. So, the natural thing to ask is are there any other plugins active (in particular, I’m wondering if there is a ‘security’ plugin that is interacting in a goofy manner)? And, if there are other plugins active, does the problem go away after deactivating all plugins other than Breadcrumb NavXT?

    @derek1957 If the code provided by @designlions didn’t work for you, I would check to ensure it actually ran (a test var_dump or die statement). If it is running but not working, I’m not sure what to say other than there is something very unique with your setup. I would be interested on the answers to my 2 questions posed in the above paragraph and any other information you could provide about your setup.

    Thread Starter kappesante

    (@kappekappesantecom)

    quick update meanwhile i keep testing: no security plugins installed. i’m using oxygen to design pages and templates. the codeblock works and i am able to customise everything. dunno if i really need to touch the plugin settings since this little thing is actually working for my needs, but i’m pretty curious about what i could find in the settings. i am also curious (since i am a web designer and not a developer and php is a strange new world i barely see in my life) if there are ways to implement breadcrumbs without plugins.

    <?php if ( function_exists( 'bcn_display' ) && ! is_front_page() ) { ?>
    <div class="breadcrumbs" typeof="BreadcrumbList" vocab="https://schema.org/">
        YOU ARE HERE: <?php bcn_display(); ?>
    </div>
    <?php } ?>

    per farlo funzionare bisogna installare la versioneVersione 7.0.0

    Same issue.

    • Using admin account.
    • No security plugins installed.
    • Fresh install.

    This has never happened before.

    • This reply was modified 11 months, 1 week ago by babyboy808.
    Plugin Author John Havlik

    (@mtekk)

    I finally found the issue. It was due to introducing namespacing and not updating a check for WP_Term properly. This has been fixed in the GitHub master branch, and is tracked by the following GitHub issue: https://github.com/mtekk/Breadcrumb-NavXT/issues/269

    Long story short, anyone who had Breadcrumb NavXT 6.6.0 likely won’t see this issue as they already had the capability added to the administrator role (WordPress caches capabilities assigned to a role). However, new sites will definitely experience this problem (a few of the more recent reports on this issue helped narrow down what was happening, thanks to everyone who reported the issue).

    @mtekk tested on 100% clean WordPress install (clean and WordPress installed from 0) and still have the issue. Setup:

    `WordPress 5.8.2
    PHP 7.4.27
    Active theme: Twenty Twenty-One v1.4
    Active plugins: Breadcrumb NavXT v7.0.1′

    What was done: clean WordPress install. First thing installed was Breadcrumb NavXT v7.0.1 and I was unable to access /wp-admin/options-general.php?page=breadcrumb-navxt with message “Sorry, you are not allowed to access this page.”

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘You do not have permission to access this page’ is closed to new replies.