[resolved] You do have sufficient permission... (3 posts)

  1. writerdave
    Posted 3 years ago #

    I was a bad boy and made a mess of a few things on my website. I attempted to restore the core files and the database and got a bunch of error messages. I traced them to a problem with a cache plugin. I was able to remove the offending plugin and all the changes it had done to core files. I also put a fresh, new copy of WordPress on my server.

    My site is now visible to visitors, although some of the plugins are screwed up at the present time. I could fix that, except when I try to login, I get the error message:

    You do not have sufficient permissions to access this page.

    I spent hours searching that problem and attempting the solutions presented and nothing has worked. Some of the solutions I have tried are:

    1. Installing a new default theme and setting it as my site's theme.
    2. Disabling all plugins through phpadmin.
    3. Checking the user_meta table in the database to ensure I had the proper admin privledges. (I did.)
    4. Creating a new admin account through phpadmin and then logging in with that user. (Received same message.)
    5. Trying to login with a generic username I use for testing. (Same message -- it appears no one can log into the site.)
    6. Checking that the database name and table prefix in wp_config is correct. (They were.)

    I am at the end of my experience. I think what I need is an expert to go sniffing around in CPanel to see what's wrong. Either that or advice on some other possible fix I haven't tried.

    Thanks in advance.

  2. Rock Solid Design
    Posted 3 years ago #

    Do you have a working backup? If so place it back.

    Seems like you have been doing a lot of (unneccesary) edits in the database which might have permanently screwed your insatllation.

    Try correctly disabling the plugins via FTP by renaming the folders.

  3. writerdave
    Posted 3 years ago #

    Problem solved.

    The culprit was an incomplete restoration of a full backup. Apparently not all files had been restored during the restoration.

Topic Closed

This topic has been closed to new replies.

About this Topic