Support » Fixing WordPress » You are not allowed to edit this post. – when trying to insert post

  • Hi, I hope someone can help or, at least, point me in the right direction.

    I have had to move my blog to new hosters and have had a lot of problems. Eventually I found a hosing company and restored everything and, although everything looks OK, it won’t let me add a new post. First there is no ‘Post’ button – only ‘Save Draft’, ‘Preview’ (which doesn’t work anyway) and ‘Submit for Review’. If I try to Save Draft or Submit – I get the ‘You are not allowed to edit this post.’ message.

    Also I cannot add a new user. I enter the details and it comes up as a blank which I can only delete directly from the database – not through WP.

    I suspect it’s something to do with the User record and it’s somehow become corrupted or is missing something. I have tried every suggestion I can find for similar problems including; disabling Plugins, changing theme, restoring wp-includes and wp-admin directories and one that suggested a different entry for the wp-usermeta data but, unfortunately, nothing works.

    I’ve tried to find the correct structure for the database so I can find out if there are any fields wrong or missing but I can’t find a place which shows the structure.

    Can anyone help? Please?

    Many thanks

Viewing 3 replies - 1 through 3 (of 3 total)
  • I have the same error – can’t submit posts even as an admin. I am using WP 3.13. I also cannot add new users – it adds the user and then sends a confirmation with blank username and password.


    In the end, I found that it was restoring the database directly through SQL that caused the problem. In fact, it was the restoring of the posts table through phpMyadmin that seemed the break the ability to edit/add posts and users. The solution (for me) was to restore the database to a temporary site then take a WordPress backup of everything. Then on the real site I installed WordPress, deleted the records (via phpMyadmin) from everything except Options and Users and restored the backup through WordPress. Then I restored (through phpMyadmin) the links table.

    It meant I had to work to get everything back as it was (i.e. the Widgets and the layout) but, at least, I have all the posts back and can now do full editing, etc.

    Good luck.

    I am having the same issue. I can edit posts but I am not able to create new ones. I cannot add new users either. Is there a way of fixing this without having to rebuild the entire site?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘You are not allowed to edit this post. – when trying to insert post’ is closed to new replies.