Support » Fixing WordPress » You are not allowed to edit this post

  • Resolved chuffer


    Please please help !
    I get the above message and believe me I have tried every suggested option and reply going back probably about 200 support threads
    I recently upgraded to 3.1.2 and backed up my db _TCC to an SQL file on my computer .
    when I upgraded my server and sql db I imported my old db into _wordpres DB and found that I only get the submit for review button but can edit old posts and pages .
    It must be something to do with the db but I have tried the link
    and also tried to edit the wp_user_role in wp_options as suggested by nsanden by inserting
    a:5:{s:13:”administrator”;a:2:{s:4:”name”;s:23:”Administrator|User role”;s:12:”capabilities”;a:51:{s:13:”switch_themes”;b:1;s:11:”edit_themes”;b:1;s:16:”activate_plugins”;b:1;s:12:”edit_plugins”;b:1;s:10:”edit_users”;b:1;s:10:”edit_files”;b:1;s:14:”manage_options”;b:1;s:17:”moderate_comments”;b:1;s:17:”manage_categories”;b:1;s:12:”manage_links”;b:1;s:12:”upload_files”;b:1;s:6:”import”;b:1;s:15:”unfiltered_html”;b:1;s:10:”edit_posts”;b:1;s:17:”edit_others_posts”;b:1;s:20:”edit_published_posts”;b:1;s:13:”publish_posts”;b:1;s:10:”edit_pages”;b:1;s:4:”read”;b:1;s:8:”level_10″;b:1;s:7:”level_9″;b:1;s:7:”level_8″;b:1;s:7:”level_7″;b:1;s:7:”level_6″;b:1;s:7:”level_5″;b:1;s:7:”level_4″;b:1;s:7:”level_3″;b:1;s:7:”level_2″;b:1;s:7:”level_1″;b:1;s:7:”level_0″;b:1;s:17:”edit_others_pages”;b:1;s:20:”edit_published_pages”;b:1;s:13:”publish_pages”;b:1;s:12:”delete_pages”;b:1;s:19:”delete_others_pages”;b:1;s:22:”delete_published_pages”;b:1;s:12:”delete_posts”;b:1;s:19:”delete_others_posts”;b:1;s:22:”delete_published_posts”;b:1;s:20:”delete_private_posts”;b:1;s:18:”edit_private_posts”;b:1;s:18:”read_private_posts”;b:1;s:20:”delete_private_pages”;b:1;s:18:”edit_private_pages”;b:1;s:18:”read_private_pages”;b:1;s:12:”delete_users”;b:1;s:12:”create_users”;b:1;s:17:”unfiltered_upload”;b:1;s:14:”edit_dashboard”;b:1;s:14:”update_plugins”;b:1;s:14:”delete_plugins”;b:1;}}s:6:”editor”;a:2:{s:4:”name”;s:16:”Editor|User role”;s:12:”capabilities”;a:34:{s:17:”moderate_comments”;b:1;s:17:”manage_categories”;b:1;s:12:”manage_links”;b:1;s:12:”upload_files”;b:1;s:15:”unfiltered_html”;b:1;s:10:”edit_posts”;b:1;s:17:”edit_others_posts”;b:1;s:20:”edit_published_posts”;b:1;s:13:”publish_posts”;b:1;s:10:”edit_pages”;b:1;s:4:”read”;b:1;s:7:”level_7″;b:1;s:7:”level_6″;b:1;s:7:”level_5″;b:1;s:7:”level_4″;b:1;s:7:”level_3″;b:1;s:7:”level_2″;b:1;s:7:”level_1″;b:1;s:7:”level_0″;b:1;s:17:”edit_others_pages”;b:1;s:20:”edit_published_pages”;b:1;s:13:”publish_pages”;b:1;s:12:”delete_pages”;b:1;s:19:”delete_others_pages”;b:1;s:22:”delete_published_pages”;b:1;s:12:”delete_posts”;b:1;s:19:”delete_others_posts”;b:1;s:22:”delete_published_posts”;b:1;s:20:”delete_private_posts”;b:1;s:18:”edit_private_posts”;b:1;s:18:”read_private_posts”;b:1;s:20:”delete_private_pages”;b:1;s:18:”edit_private_pages”;b:1;s:18:”read_private_pages”;b:1;}}s:6:”author”;a:2:{s:4:”name”;s:16:”Author|User role”;s:12:”capabilities”;a:10:{s:12:”upload_files”;b:1;s:10:”edit_posts”;b:1;s:20:”edit_published_posts”;b:1;s:13:”publish_posts”;b:1;s:4:”read”;b:1;s:7:”level_2″;b:1;s:7:”level_1″;b:1;s:7:”level_0″;b:1;s:12:”delete_posts”;b:1;s:22:”delete_published_posts”;b:1;}}s:11:”contributor”;a:2:{s:4:”name”;s:21:”Contributor|User role”;s:12:”capabilities”;a:5:{s:10:”edit_posts”;b:1;s:4:”read”;b:1;s:7:”level_1″;b:1;s:7:”level_0″;b:1;s:12:”delete_posts”;b:1;}}s:10:”subscriber”;a:2:{s:4:”name”;s:20:”Subscriber|User role”;s:12:”capabilities”;a:2:{s:4:”read”;b:1;s:7:”level_0″;b:1;}}}
    Nothing works . please any help is appreciated greatly .

Viewing 7 replies - 1 through 7 (of 7 total)
  • What version of WordPress are you running now and what version were you running when you created the database backup?

    I am having the same issue. I have tried all suggestions listed in this forum that relate and have had no luck. If anybody can help with this issue i would be willing to pay $ for any help.

    Okay here is what worked for me and I am just going to go with it .
    First new install 3.1.3
    then copied “DATA ” only from my old _TCC DB to my new _golf DB for the wp_post table and the wp_comments table to new tables in _golf DB . These also had a different prefix and are now cf_posts and cf_comments .
    All this did was make sure that I had my old posts and comments in the new DB along with the new permissions for the admin unchanged . This allows me to add new posts and pages and edit the old ones . I then added anything like pictures in old posts my hand after reloading them in the WP media library .
    Not the best solution just one that eventually worked for me . I did try and add wp_options in the same manner and it reverted back to the review for submission page so the problem is definetley in there and I will eventually root it out .
    Sorry thats the best I can do for now .
    Asmi — I was on 2.7 now using 3.1.3 and tried other previous upgrades before that with the same result . Is it a WP bug or an SQL bug I don’t know yet but it is a BUG .

    I have done a complete reinstall and didn’t upload any old tables.. and I still am not able to create new post. At first it looked like i was going to be able to but when i hit “publish” it went right back to “You are not allowed to edit this post.” and now I only get the “Submit for review” I have 2 databases now and both are not working. I have several other wordpress sites and I do not have this issue on them. I hope somebody can help with this issue. Thanks’

    Sorry Zowieguy I can’t help . I’m a complete novice to this stuff and bumbled my way into my fix eventually . I hope you find the solution soon as I know how frustrating it is trying to get support like this . Is there anyway to get support from a wordpress developer or other person so you don’t always have to waite 12hrs or more .

    Hi zowieguy,

    Still you have same problem or solved??

    Solved but not solved.. I ended up up just starting over and manually entering in posts instead of uploading tables. Apparently there was an issue with the the table structure. Not sure if it is a bug in WP or was an issue on my end. Anyways, my site is working and I have moved on to greater things. 😛 cheers’

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘You are not allowed to edit this post’ is closed to new replies.