Support » Fixing WordPress » You are not allowed to edit this post.

  • i did a fresh install of 3.1.2 and a new database through Godaddy hosting. i can’t create any posts or pages without getting this error:

    You are not allowed to edit this post.

    i also tried to trash some existing posts and got similar errors about how i can’t move to trash.

    i’m the only user set up and i’m an administrator – it shows me logged in as well. i also disabled all plugins and reverted to the base theme – same story.

    the only thing i really did that was extraordinary is import some posts from an older version of the blog and map the users to the one user account.

    if anyone can help i’d appreciate it – pulling my hair out over here.

Viewing 15 replies - 1 through 15 (of 25 total)
  • try creating a new admin user and test
    there is no known bug like this

    you are on a linux server at godaddy’s, right? because their windows servers stink

    linux server, yeah.

    same issue with a new user; creates successfully, logs in successfully, but same errors.

    yeah i read those before posting – no luck there. i searched for the table row he mentioned but it wasn’t there; and the other link in there someone links to is about 4 years old and doesn’t seem relevant.

    i think your two links are the same, actually.

    anyone else have any ideas on this?

    The same exact thing has been happening to me. I import an xml file of old tumblr posts using the WordPress Import plugin, and the admin privileges are disabled when trying to add a new page or post with the same message:

    You are not allowed to edit this post.

    This is seriously infuriating. Help please?

    so maybe it has to do with the importing of xml files in some way…does that help any moderators to shed any light on the issue?

    I’m also getting the same issue.

    Can not create a new post. I get message “You are not allowed to edit this post”

    I can edit old posts.

    I tried adding a new admin user, but it doesn’t work. I get a confirmation email with the username blank. But no user entry is made to the database.

    I have tried disabling all plugins.

    I am using version 3.1.2 of wordpress on linux server on Dreamhost.

    I tried rolling back (delete all, and reinstall) to 3.0.2 and restored backups, but still get the same issue … strange. I think something has changed in DB configuration on the web host, but I don’t know what I am looking for!

    I know I have made some entries back when I was using 3.0.2 so I don’t know why the re-install still have issues.

    I have the same problems . upgraded to 3.1.2 also asked my host service (IXwebhosting— very helpful ) who could find nothing wrong with the db and done a complete new install and this time only copied the post table from old db to new db and guess what .. problem of being unable to post came back . The problem is in the db but only when you try to keep your old posts .
    Surely this must narrow the solution down a lot to someone who really knows wordpress code . I am desperate and very very unhappy with all the supposed solutions people keep repeating on this forum . Anyone out there who can really Help ?

    yeah i’m dead in the water too until someone can help narrow this down….

    esmi

    (@esmi)

    Forum Moderator

    well just fyi in regards to Esmi’s link and some of its suggested solutions:

    – just tried the forced database upgrade and that didn’t do anything – same problems.

    – commenting out a certain string in the wp-settings.php file was a no go too, as the string in question doesn’t even seem to exist in the latest version of the wp-settings.php file.

    – i tried updating the table names (changing “wp_user_roles” to “wp_new_user_roles” etc) and that actually made me unable to even log in to wordpress at all.

    so this appears to be yet another link that doesn’t contain any actual viable solutions. feel free to double check me but i think those were the main 3 suggestions in the thread.

    how did you change the db version in phpadmin . Tried the suffix fix and no joy there either and also tried the link to
    http://beconfused.com/2007/how-to-solve-you-do-not-have-sufficient-permissions-to-access-this-page-in-wordpress/
    without much joy either .
    surely this is a bug if you can’t add records to the db easily . Surely everything like transferring posts from old db to new db should be backwards compatable.
    Not very impressed so far

    chuffer – the db version is a line in the wp_options table (there are about 220 rows in there and i didn’t see it on the first page). when you hard change it to an old number and refresh your wp admin page it sees it’s out of date, updates it, and you’re set. unfortunately that didn’t change anything.

    i’m not too happy at the moment either – i picked wordpress for its ease of use and i’m already several weeks behind schedule because of bugs…

    h-e-l-p.

    Thanks for that
    No good though – big suprise eh !
    Come on people somebody must have figured this out by now . WordPress is a clever installation and written by clever people so please help us dummies
    TA .

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘You are not allowed to edit this post.’ is closed to new replies.