Smallerik File Browser
You are not allowed to edit these settings (11 posts)

  1. der-mali
    Posted 3 years ago #


    I installes Smallerik File Browser on my web page and it worked great.
    Then I did a stupid thing: as a security measure I deleted the only "admin" account and got one with a new login.

    Since that time when I go to the dashboard and the WPFIB settings the only message is:

    You are not allowed to edit these settings
    You should be listed in the Permissions -> Trusted Authors option to access this functionality
    Current settings = [1]

    I deactivated all other plug-ins - problem still there.
    I deleted the WPFIB completely and also wiped the database entries in wp_options.
    I used the old admin account again.

    I still get the error message.
    Maybe there are settings in the database I was not able to erase and are still there?

    This "current settings = [1]"
    where can I change that and which value should I use?

    I do not want to set up my whole page from the start up.

    Please advise!

    WP is 3.4.2 and WPFIB is 1.0 on an apache server


  2. der-mali
    Posted 3 years ago #

    Oh, the page with the [wpfib] says:

    Cannot display a file repository: this page was las modified by , who is not in the Trusted Authors list of the Smallerik File Browser plugin

  3. mvdw310
    Posted 3 years ago #

    Someone who knows to solve this problem.
    I got the same problem as "der-mali"
    or is there an other plugin what does the same or almost the same ?

    Grtz from holland
    Manfred vd Waarsenburg

  4. der-mali
    Posted 3 years ago #

    Hello Manfred,

    it is working again here now.
    It has been a while that the error occured but let me think what I did to fix it:

    I deleted the whole FTP folder for the plugin.
    Then I went to MySQL and also deleted all entries that where from this plugin. Let me think: the term I was looking for in MySQL was
    "wpfib" (This plugin). Search for this term and deletee all entries.

    Please make a copy of the entire database first to make sure your WP site will still run after this process.

    Then install and activate the plugin anew and it should work.

    I hope I didn't forget anyhing since it is a while ago.

    The deleting of the database entries will make sure that all permissions will be reset.
    It is a hard reset which is very "brutal" but it worked.

  5. mvdw310
    Posted 3 years ago #

    Hmm I have tryed to uninstall the plugin and remove the entries from de SQL dbase but nothing worked for me.
    I have to search tomorrow why it doesn't work for me

    i found only 2 entries in the SQL dbase, maybe there are some more.

    I hope i can find a solution because i need a frontend filebrowser.

    thanks for the help

  6. der-mali
    Posted 3 years ago #

    I think you are right.
    Now I remember: I did the above before but it didn't work.
    The bad news is that I "killed" my entire page but I was able to export the content (I have only 5 pages there and no posts) under
    Tools - Export
    Then I started the whole thing anew with uploading WP and killing the entire MySQL database.

    This might not be a solution for you but it worked for me since my site was very fresh still with not so much content.


    Sorry that I do not have better news for you.

  7. mvdw310
    Posted 3 years ago #

    Thanks for the answer, I got to search for an other solution.

    thanks anyway

    If someone knew a file browser plugin :-)

  8. der-mali
    Posted 3 years ago #

    Look here:

    There are also some php scripts, independent from WP, which have a nice design:

    I like the above "Dir-List" very much

  9. Josh Nankivel
    Posted 3 years ago #

    I discovered it defaults to having user id = 1 as the only one with any admin rights on the plugin settings. So in /plugins/wpfib/includes/options.php line 263 - change the return to false temporarily, add your admin username to the permissions and then change it back.

  10. SomniumLucidus
    Posted 3 years ago #

    Hey, thanks, Josh! This solved the problem for me. (The OP may want to mark this as “solved”.)

  11. albertop74
    Posted 2 years ago #

    Thanks to solve the problem!!! I logged in with user admin and I could change the options!!!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Smallerik File Browser
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic