WordPress.org

Support

Support » Installation » [Resolved] You are not allowed to call this page directly.

[Resolved] You are not allowed to call this page directly.

  • I get this message when trying to update my wordpress.
    Clicking on “WordPress 3.0.1 is available! Please update now.” It takes me to …/wp-admin/update-core.php hwith the message: You are not allowed to call this page directly.

    Then what?

Viewing 7 replies - 1 through 7 (of 7 total)
  • That error message is not coming from WordPress – That string is not in any of the WordPress source files.

    • What host are you on?
    • How did you install WordPress?

    You are right, the message is not in the update-core.php on that server, even though that is the page displayed by the browser.

    I run this on a hosting company server.
    I innstalled wordpress by the book, several years ago, I have been updating wordpress several times during this period (by clicking the link in dashbord).
    I have never experienced this during updates earlier.

    I am with hostpapa.com and am getting exactly the same error message. It was installed manually by me using ftp a few weeks ago v2.9.7 now I want to upgrade to 3.0.1. So am I left with only the manual upgrade option?

    try deactivate all your plugins 1st then you can go to dashboard and upgrade automatically

    A plug in seems to be the problem, check out: http://wpengineer.com/wordpress-3-multisite-settings/

    the solution to this problem is here
    http://wordpress.org/support/topic/wp-adminupdate-corephp-gives-a-you-are-not-allowed-to-call-this-page-directl

    it is the NextGEN ImageFlow
    Disable this plug-in, run your update, and you can RE-enable it afterwards.

    bhatiacane

    @bhatiacane

    thanks for your reply but.

    i shift my site database to dreamhost server not upgrade.

    i found problem when i import wp_usermeta table then only show this prob.(message : You are not allowed to call this page directly <—i am not able to login)

    if i not import wp_usermeta and use new
    than
    in /wp-admin/users.php

    shows all user role : None

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] You are not allowed to call this page directly.’ is closed to new replies.
Skip to toolbar