Support » Fixing WordPress » You are currently editing the page that shows your latest posts.

  • Why, all of a sudden, does the set Blog page become uneatable in version 4.2.2?
    I now get this message, instead of the visual/text editor for that page. “You are currently editing the page that shows your latest posts.”
    There are also no options to choose sidebars or page templates anymore. This has occurred on two different WordPress sites I’m working on.

    I have set the Posts Page via Customize to the appropriate page, and it does work as it should to display the posts, etc… but every time I go to Edit page I get the message “You are currently editing the page that shows your latest posts.”

    This has happened in both Twenty Twelve and Mantra, both child themes. Both current versions.

    This is not good! Help please, and thank you!

Viewing 15 replies - 1 through 15 (of 20 total)
  • The solution is to go to settings>reading>and under post page select another page.

    It’s actually showing that message because that’s the page your posts go to. It’s just an message.

    I hate this addition.. Often our clients like to have custom text on the “main” blog page, and the “blog” PAGE is the perfect place for this. Now you can’t do this out of the box.

    Really starting to hate WordPress lately.. Anyhow, heres a fix if you’re interested.. Add this to your theme functions.php, or create a plugin with this code:

    if( ! function_exists('fix_no_editor_on_posts_page'))
    {
    	/**
    	 * Add the wp-editor back into WordPress after it was removed in 4.2.2.
    	 *
    	 * @param $post
    	 * @return void
    	 */
    	function fix_no_editor_on_posts_page($post)
    	{
    		if($post->ID != get_option('page_for_posts'))
    			return;
    
    		remove_action('edit_form_after_title', '_wp_posts_page_notice');
    		add_post_type_support('page', 'editor');
    	}
    	add_action('edit_form_after_title', 'fix_no_editor_on_posts_page', 0);
    }

    If anyone is interested, instead of using the above code, you can install this plugin that I created which will add the editor back:

    https://wordpress.org/plugins/add-editor-to-page-for-posts/

    Julia

    (@julialifetime)

    Hello,
    I’m so confused by this update!
    Thank you for providing a solution. First I added your code to the functions file but it didn’t change.Then I installed your plugin and yes the content area reappears but no content or blog posts show on the page and the layout doesn’t show either…
    The page is pw protected. Please logon to see the blog:
    developer
    1212lTa1313

    http://adoptforlife.wpengine.com/blog-test/

    Any ideas?

    Hi Julia,

    The issue with your posts not showing on the website is not the same as the issue as the original poster. The plugin I wrote will not help you with your issue unfortunately.

    Can’t help you with the problem unfortunately, it’s not possible to debug this without a login to the websites wp-admin (which I do not recommend you paste on this forum).

    Please check a few things:

    1. In wp-admin, check Settings->Reading page. Do you have “blog-test” set as your “page for posts”?
    2. Ensure you have cleared your wp-engine cache .
    3. Reset permalinks (Settings->Permalinks) just press save/update.

    I pasted your code into the functions.php – it got rid of the message “You are currently editing the page that shows your latest posts.”
    BUT the is NO VISUAL EDITOR, no place to write the post.

    This is an older hand built WP site, so I have far too many plugins, but will add yours if I need to.

    Why is wordpress not on this. This website (www.marinediscoverycenter.org) has several blogs – some dedicated to restoration, others to marine mammal stranding, etc – so, I have set up the “blog-rolls” in the appearance>menus and depending on what category the post is, that is the page it will show on.

    Please assist – I thank you!

    also, the categories are missing

    mahfoof

    (@mahfoofgmail)

    Thank you crgeary for the code , I used the code and got back my wp editor but the (publish button) replaced with (submit for review button)? so please share if you have any Idea to solve this issue . . thank you again

    This is really annoying. Anyway, after doing some test experiment, seems legit but i think i will wait until WP staff update this issue.

    Ok, if you create a static page and point a certain page you would want to be a Blog Post area, here’s my step:

    1. Go to “Pages”, Fill up the content editor to your desired text. Then, publish.
    2. Go to Settings > Reading and Point your page that you would like to be the “Posts Page”. Then save.
    3. Go back to “Pages” and see your stuff there and continue update the content.

    Note: If you accidentally erase the content inside your content editor. Head to your right panel under Publish window, and look for the Revision link to restore your last work.

    Hope this help.

    crgeary,
    Your plugin lets us edit the Blog page but the posts still aren’t being shown on the page.

    I also don’t have a selection of blog-test to set the page for posts as.

    This stuff is getting way beyond my menial tech abilities.

    AJ

    (@akwasiijunior)

    @Markianam

    thanks !

    @crgeary thanks for the code it work for me

    So the message disappears
    “you are currently editing the page that shows your latest posts”.
    Which is a good start!

    But my page query to the blog page pulls in the latest blog post, not the blog page 🙁

    Any ideas anyone?

    @beormalte

    please start a new topic. http://codex.wordpress.org/Forum_Welcome#Where_To_Post

    what theme are you using?

    generally, as the blog page will be using the template home.php or index.php, it will not show the content of the page itself.

    depending on your theme, you will need to edit the corresponding template (in a child theme) and add a few lines of code.

    frankayan

    (@frankayan)

    Hello! Please can someone walk me through how to remove unwanted space in the front page of my site. Thanks!

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘You are currently editing the page that shows your latest posts.’ is closed to new replies.