• Resolved tezalsec

    (@tezalsec)


    Hi,

    although I can not reproduce it myself, I get several messages from people who can not register, because they keep getting the validation error: “you are already registered” while this is not the case. I checked and doublechecked. No bleedthrough from other events either, as it was the first one.

    Do you have any explanation or solution for this? I really don’t know where to start debugging this…

    Thanks!

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author roundupwp

    (@roundupwp)

    Hmm this hasn’t come up before as far as I know. Do you have any caching on your site that might affect the database? Possibly object caching? Otherwise, is there anything in common with the people having this issue that you are aware of?

    Thread Starter tezalsec

    (@tezalsec)

    I have Supercache active, but excluded it on the registration page. No object caching.

    I did notice that when someone couldn’t register, when I put in their email address myself, the validation error did not appear. It sounds like some form of clientside caching, but I am assuming that should not be possible, since there was no previous registration and you probably use ajax in the form.. So I have no idea.

    • This reply was modified 2 months ago by tezalsec.
    Plugin Author roundupwp

    (@roundupwp)

    I am going to make some changes to the code related to this feature. I’m hoping it will avoid any edge case scenarios like you are describing where either the server or the JavaScript misreads the result of the check.

    It should be available in an update either today or tomorrow morning. After updating, let me know if there are still reports of this though it is difficult to debug if the issue can’t be recreated like you mentioned!

    Plugin Author roundupwp

    (@roundupwp)

    The update is now available. Can you let me know if it helps? Like I said no one else has mentioned this but I’m guessing someone else has had an issue but maybe it was not reported. So I’d like to try to solve it if possible!

    Thanks,

    Craig

    Thread Starter tezalsec

    (@tezalsec)

    Thanks for the speedy action 🙂 I just updated, so let’s see what happens.

    After reading your changelog notes, I am suspecting now it was just a matter of people accidently starting or ending their email address with a space.

    Besides auto trimming start/end spaces, maybe you could choose to differentiate in validation error messages, so in that case it would say “invalid email address” instead of “you are already registered”?

    This last issue is still the case, so maybe that’s something for a next update? 🙂

    Thanks again.

    Thread Starter tezalsec

    (@tezalsec)

    I see you include the space issue in your last update. 🙂

    I can confirm now for sure this was the issue with the occurrences I spoke about. I pointed the space issue out to them, and afterwards they registered succesfully.

    Glad its sorted out. Again, I hope there will be more a bit more differentiation in validation message categories, it avoids looking for errors in the wrong direction. 🙂

    Cheers.

    Plugin Author roundupwp

    (@roundupwp)

    Hey again tezalsec,

    Typically there is a different message. Are you using a translation file or anything? I wonder if the two different messages are translated to the same thing perhaps.

    Plugin Author roundupwp

    (@roundupwp)

    This thread has been quiet for awhile now so I’ll mark it as resolved but let me know if you have more thoughts!

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.