Support » Plugin: YOP Poll » YOP Poll does not work with some themes and plugins

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author YOP

    (@yourownprogrammer)

    Hi wlad_brova,

    We will run some tests with the themes you mentioned and get back to you as soon as possible.

    You mention that some plugins have conflicts. Please mention which plugins and what kind of conflicts, so we may assist.

    Best regards,

    YOP Team

    Why i am unable to use some of plugin to my website Homeopathy

    It doesn’t work with ANY theme in WP 3.5.1 (for ex. “native” Twenty Eleven (on images!))
    After poll closing date it’s results does not show anything(((, except poll dates. Any qwestions, any percentage of votes, any ANSWER-RESULT-BARs.
    See yoursefl: Image 1
    So, your default poll template AFTER DATE having code

    This poll is closed!
    Poll activity: <br>
    start_date %POLL-START-DATE%<br>
    end_date %POLL-END-DATE%<br>
    
    Poll Results:
    <div id="yop-poll-question-%POLL-ID%" class="yop-poll-question">%POLL-QUESTION%</div>
    <div id="yop-poll-answers-1" class="yop-poll-answers">
    	<ul>
    		[ANSWER_RESULT_CONTAINER]
    		<li class="yop-poll-li-result-%POLL-ID%">
    			<label class="pds-feedback-label">
    				<span class="pds-answer-text">%POLL-ANSWER-LABEL%</span>
    				<span class="pds-feedback-result">
    					<span class="pds-feedback-per"> %POLL-ANSWER-RESULT-LABEL%</span>
    				</span>
    			</label>
    			<span class="pds-clear" style="display: block;clear: both;height:1px;line-height:1px;"> </span>
    	%POLL-ANSWER-RESULT-BAR%
    		</li>
    		[/ANSWER_RESULT_CONTAINER]
    	</ul>
    </div>
    %POLL-VOTE-BUTTON%

    What is: Image 2

    Plugin Author YOP

    (@yourownprogrammer)

    Hi wlad_brova,

    To see the results, go to Edit (in the menu that appears when you drag your mouse over the poll), and in the “View Results Options” section, in “View Results:” choose “After Poll End Date” and save the changes.

    Best wishes,

    YOP Team

    Thanks a lot! … But, anyway, there is a conflict, which does not generally edit the poll with some themes and plugins ((((

    If you are interested in, I’ll give you a link where you can download a sample site and its database. Install it on a local server and try it for yourself)))

    Plugin Author YOP

    (@yourownprogrammer)

    Hi wlad_brova,

    Please send the link. We will download the sample and see where the problem is.

    Regards,

    YOP Team

    Hi! I hope it’s not late 4’U )))
    Please, download the package from my Dropbox

    Thank you in advance for your care!
    I shall wait impatiently for result of research of a problem.

    Plugin Author YOP

    (@yourownprogrammer)

    Hi,

    We download the files you sent and it seems that the problem is with this plugin, bind-user-to-cat, that generates some errors.

    To fix it you can edit bind-user-to-cat.js and replace

    function init() {
    var t = document.getElementById("bindusertocat");
    var d = document.createElement("div");
    d.id = "addRow";
    var b = document.createElement("input");
    b.type = "button";
    b.value = "+";
    t.parentNode.appendChild(d).appendChild(b);
    addDeleteButtons(t);
    b.onclick = addRow;
    //document.createElement("input").type
    }

    with

    function init() {
    var t = document.getElementById("bindusertocat");
    if ( t ) {
    var d = document.createElement("div");
    d.id = "addRow";
    var b = document.createElement("input");
    b.type = "button";
    b.value = "+";
    t.parentNode.appendChild(d).appendChild(b);
    addDeleteButtons(t);
    b.onclick = addRow;
    //document.createElement("input").type
    }
    }

    [Please post code & markup between backticks or use the code button. Your posted code may now have been permanently damaged by the forum’s parser.]

    Please let us know if there’s anything else we can help you with.

    Best wishes,

    YOP Team

    Thank you very much! Your plugin is working completly…
    Best regards,
    Wlad Brova

    Hi YourOwnProgrammer,

    I have used the plugin and searched for the error, thought maybe someone also had the same and a soultion, but it seems that we are many with the same warning and no solution
    Warning: Invalid argument supplied for foreach() in ... wp-content/plugins/yop-poll/inc/yop_poll_model.php on line 66

    Can any one please help, needed urgently. Thanks in advance.

    From the above warning, when you do a google search, you get alot of sites that have the same problem, which becomes common, but maybe never looked into it.

    I searched this below into google and got over 100 results with the same warning on very many site that report the same.

    Warning: Invalid argument supplied for foreach() yop_poll_model.php on line 66

    Plugin Author YOP

    (@yourownprogrammer)

    Hi krisio21,

    Please uninstall the plugin and run a fresh install.
    Let us know if you still have this problem.

    Best wishes,

    YOP Team

    By way of gratitude, I have made translation of a plug-in into the Ukrainian language. Would appreciate it if you will build my translation in assembly of the next update of your’s cool plugin …)))

    does not work with tablepress
    thanks.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘YOP Poll does not work with some themes and plugins’ is closed to new replies.