[resolved] [Theme: Yoko] No way to get child theme working (2 posts)

  1. fcornia
    Posted 3 years ago #

    I'm really in trouble with this...

    No way to get a Child Theme for Yoko working on the hosting machine (ARUBA - PHP 5.3.13). I have built the theme over my local machine (easyPHP 5.3.8) and everything is fine there.

    WordPress say parent theme "Yoko" is missing; i have tried either solution: upload the couple parent-child (working over my local machine) via FTP or fresh installing Yoko via wordpress utility... Same version of yoko 1.0.5 of course.

    I'm sure the header of the child is correct otherwise it won't work over my local machine...

    Theme Name: Yoko-doppiotolup
    Theme URI: http://www.elmastudio.de/wordpress-themes/yoko/
    Description: Customizzazione del tema YOKO per il sito www.doppiotolup.it
    Author: Fabrizio Cornia
    Author URI:
    Template: Yoko
    Version: 1.0
    @import url("../yoko/style.css");

    I have worked on theme development with WordPress 3.2.1 updated today at version 3.4.1 but the version doesn't seem important. Either way child theme over 3.2.1 and 3.4.1 is rolling nice on my local machine and miss the parent theme "Yoko" on the hosting server...

    Another try: i have also writed a basical child-theme for twentyeleven and obviously... it run over the hosting server.

    Some suggestion to locate the bug???

  2. fcornia
    Posted 3 years ago #

    Okay... it was a carelessness...
    in the line
    Template: Yoko
    the "Template" is not the template name but the template directory and need to be all lowercase, as the yoko's theme directory...
    This thing is well descripted in http://codex.wordpress.org/Child_Themes
    Now i don't know why my local installation display correctly the child theme not listed correctly, but this is not important for me.

Topic Closed

This topic has been closed to new replies.

About this Topic