WordPress.org

Support

Support » Plugins and Hacks » Yoast WP SEO – Meta Problem – Please help

Yoast WP SEO – Meta Problem – Please help

  • casperremmer

    @casperremmer

    Hi all

    I hope someone can help me resolve this issue. I have a WP site setup with yoast. No other SEO plugins are installed.

    Titles are working fine and everything – BUT – I cant seem to get the META descriptions to work.

    My header.php looks like this:

    [Code moderated as per the Forum Rules. Please use the pastebin]

    Please can somebody help me, and check what is wrong in this???

    Thanks alot

    Best

    Remmer

Viewing 8 replies - 1 through 8 (of 8 total)
  • Moderator Kathryn

    @zoonini

    Automattic Happiness Engineer

    You need to make sure you have the following line just before your closing </head>:

    <?php wp_head(); ?>

    Reference: http://codex.wordpress.org/Function_Reference/wp_head

    While you’re at it, make sure you have the footer equivalent just before the closing </body>:

    <?php wp_footer(); ?>

    Reference: http://codex.wordpress.org/Function_Reference/wp_footer

    If you want us to look at your code, please use a pastebin. http://pastebin.com/

    casperremmer

    @casperremmer

    Hi again

    Thanks for you help so far!

    I have now inserted the entire content of my header.php

    Can anybody please tell me, whats wrong with this picture 🙂

    [Code moderated as per the Forum Rules. Please use the pastebin]

    casperremmer

    @casperremmer

    sorry here is the pastebin of my header.php

    http://pastebin.com/Ux62yXFp

    Please let me know what to do

    Best

    Casper

    Moderator Kathryn

    @zoonini

    Automattic Happiness Engineer

    Your wp_head() looks correct. Can you provide a link to a page on your site where you have tried to add a meta description?

    Side note, but why have you hard-coded an noindex/nofollow tag?

    <meta name="robots" content="noindex, nofollow" />

    This means that your site will not be spidered or indexed by search engines. If you ever want to temporarily prevent spiders from indexing you can always use the privacy setting in the WP admin area.

    Moderator Kathryn

    @zoonini

    Automattic Happiness Engineer

    Wow, I just noticed you have tons of other hard-coded meta robots tags, example:

    <?php if(is_single() || is_page() || is_home()) { ?>
    <meta name="googlebot" content="index,noarchive,follow,noodp" />
    <meta name="robots" content="all,index,follow" />
    <meta name="msnbot" content="all,index,follow" />
    <?php } else { ?>
    <meta name="googlebot" content="noindex,noarchive,follow,noodp" />
    <meta name="robots" content="noindex,follow" />
    <meta name="msnbot" content="noindex,follow" />
    <?php }?>

    If you plan to use an SEO plug-in you should remove all this stuff and let the plug-in do its job. I am guessing all these tags are conflicting with the plug-in somehow.

    Moderator Kathryn

    @zoonini

    Automattic Happiness Engineer

    p.s. what theme is this?

    casperremmer

    @casperremmer

    Hi

    The theme is Debonair. Search on themeforest.

    I get the point on the nofollow and noindex. But Google has updated since i changed he site, so it must index them??

    the site is at http://www.diskotek-soundforce.dk

    Hope somebody can help fix this metadescription issue

    Best

    Casper

    Moderator Kathryn

    @zoonini

    Automattic Happiness Engineer

    Hiya, since that is a paid theme you’ll want to contact Themeforest support as they are best placed to help with this issue. It’s not advisable to edit premium theme files yourself because changes will be overwritten the next time the theme is updated. The theme developer may already be aware of conflicts with certain SEO plug-ins, and can explain their rationale behind hard-coding in meta robots tags.

    Best of luck!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Yoast WP SEO – Meta Problem – Please help’ is closed to new replies.