Support » Plugin: Yoast SEO » yoast sitemap xml :This is not a valid URL.

  • Resolved pixelmorph

    (@pixelmorph)



    So google bot hates my sitemap.. its all there but the URLS are “not valid” perhaps because they are relative ? perhaps its the HTTPS ? I’m not sure. I have scored the forum and followed the help files.. turned the xml on and off again/ saved the permalinks … no joy.
    Im using a relative links plugin on site as well so perhaps its a conflict or.. maybe its just wrong.. is there a way to force the plugin to write out the links whith the full url (assuming that is the core issue ) I have a custom functions file in my child template and i’m not afraid of php…

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Michael Tina

    (@mikes41720)

    Upon checking your sitemap, it looks like it is using relative URLs. If you were to use absolute and full URLs, does the issue resolve?

    well sure but how do i get the pluggin to do that?

    Plugin Support amboutwe

    (@amboutwe)

    Yoast SEO, by default, uses the URLs defined in the WordPress settings under:

    Admin > Settings > General > WordPress Address (URL)
    Admin > Settings > General > Site Address (URL)

    If the URLs are correct in the settings, sometimes strange behavior may be caused by a plugin or theme conflict. Please check for plugin or theme conflicts.

    Plugin Support jerparx

    (@jerparx)

    Closed due to inactivity.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.