Support » Plugin: Yoast SEO » Yoast sitemap with 2 subdomain website

  • Resolved vanetreg

    (@vanetreg)


    Hi,

    for website optimization purpose I defined a new cookieless subdomain named “static”, I use it for serving images, css, js, and use the original “wwww” subdomain as cookie domain.
    Website works properly, except Yoast sitemap feature:
    neither
    http://www.mydomain.com/sitemap_index.xml
    nor
    static.mydomain.com/sitemap_index.xml
    shows nothing 🙁

    I disabled and re-enabled plugin but it didn’t help. Caches refreshed multiple times.

    What should I do with it?

    Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    In order to better assist you, we’ll need more information.

    • Would you mind elaborating more on how exactly did you set up your domain names for serving resources on your site?
    • Can you please share the exact URLs where the issue remains occurring for you so that we can take a look at it?
    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    Unfortunately, we think the issue is specific to your site. We’d need to investigate further but are unable to do so on these forums. You can purchase Yoast SEO Premium and receive our Premium email support and we can help you further.

    Plugin Support monbauza

    (@monbauza)

    We investigated this issue further and managed to replicate it on our testing environment. When trying to view the XML sitemap, we got a blank page and the following error in the browser’s console:

    Unsafe attempt to load URL http://static.mydomain.com/plugins/wordpress-seo/css/main-sitemap.xsl from frame with URL http://mydomain.com/sitemap_index.xml. Domains, protocols and ports must match.

    Notice that the source code of the sitemap is correctly generated. It’s just a problem with the stylesheet not being loaded properly in the browser. Google and other search engines shouldn’t have any problems reading your sitemap.

    That said, you may want to try using the wpseo_stylesheet_url filter to set the stylesheet URL for the XML sitemap to mydomain.com/plugins/wordpress-seo/css/main-sitemap.xsl (instead of the static domain). This should make browsers display the sitemap correctly.

    • This reply was modified 1 year, 8 months ago by  monbauza.
    • This reply was modified 1 year, 8 months ago by  monbauza.

    Hi @monbauza

    I disagree: Google and other SEs HAS problems with it!
    I identified issue when I found that my security plugin banned Google bots IPs because of too many 404s!
    Banned Google bots are not the best for my site’s SEO…

    I hope you devs find a fix in one of the next updates and I can change my rating.

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    If you change the stylesheet URL using the wpseo_stylesheet_url filter, does that resolve your issue?

    No, sorry, I’m not a programmer, like most of your users.

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    We understand your concern. Unfortunately, we think the issue is specific to your site. We’d need to investigate further but are unable to do so on these forums. You can purchase Yoast SEO Premium and receive our Premium email support and we can help you further.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Yoast sitemap with 2 subdomain website’ is closed to new replies.