Support » Plugin: Yoast SEO » Yoast sitemap generated invalid single page

Viewing 11 replies - 1 through 11 (of 11 total)
  • Saša

    (@stodorovic)

    At first look, it could be WPML issue. Did you install “glue” plugin – https://wpml.org/download/yoast-seo-multilingual/ ? I’d guess that “ar” is secondary language?

    Thread Starter jamesoh5

    (@jamesoh5)

    Thank you for leaving an answer.
    – No, I first noticed that the WPML “glue” plugin exists for YOAST plug-in management.
    So far, I’ve just used Yoast plugin using Elementor pro based on other language pages created through WPML.

    – Yes, it is. “ar” means Arabic and another language page.

    Should I download a plugin called “glue” from WPML and manage yoast plugin?

    Plugin Support Maybellyne

    (@maybellyne)

    Hello,

    Thanks for reaching out.

    You mentioned that https://trabic.kr/%d8%aa%d8%b5%d8%af%d9%8a%d9%82-%d8%a7%d9%84%d8%a3%d9%88%d8%b1%d8%a7%d9%82-%d9%85%d9%86-%d8%a7%d9%84%d8%b3%d9%81%d8%a7%d8%b1%d8%a7%d8%aa/ is an invalid URL included in your sitemap. On visiting the page, it throws a 404 error. Could it be that you have found the page and deleted it?

    In any case, since the URL already throws a 404, it will be automatically removed from the sitemap with time.

    Saša

    (@stodorovic)

    Yes, you should install “glue” plugin because entire integration (including sitemaps) are moved from WPML base plugin to “glue” plugin (after activation purge cache, delete transients or disable/enable sitemap feature from Yoast settings).

    Did you enable “Adjust IDs for multilingual functionality” option? If so, I recommend to you try to disable it and check website? I think that Elementor don’t need automatic adjustments (and this issue could be side effect of this setting).

    Saša

    (@stodorovic)

    @maybellyne it’s the valid page (but wrong URL into sitemap) and it’s highly recommended to install “glue” plugin. WPML has moved a lot of integration code (for Yoast) from base plugin to “glue” plugin.

    So, there are:

    https://xxxxxx.kr/%d8%aa%d8%b5%d8%af%d9%8a%d9%82-%d8%a7%d9%84%d8%a3%d9%88%d8%b1%d8%a7%d9%82-%d9%85%d9%86-%d8%a7%d9%84%d8%b3%d9%81%d8%a7%d8%b1%d8%a7%d8%aa/
    https://xxxxxx.kr/%eb%8c%80%ec%82%ac%ea%b4%80%ec%9d%b8%ec%a6%9d/
    

    First link isn’t prefixed (missing /ar) and I think that’s Arabic translation of %eb%8c%80%ec%82%ac%ea%b4%80%ec%9d%b8%ec%a6%9d (if you open it and switch to Arabic, you will see that’s regular page).

    Thread Starter jamesoh5

    (@jamesoh5)

    @maybellyne

    The problem is that I cannot delete this page. The page does not exist anywhere on the WordPress page. The page that cannot be deleted is in the wrong form of registered in sitemap

    Saša

    (@stodorovic)

    It’s possible that there are ghosts into database (it’s possible that WPML didn’t correctly link translations). You should try to make DB BACKUP before any next action.

    You can try to remove all revisions, trash posts, … You can try to find possible duplicated posts with plugin https://wordpress.org/plugins/delete-duplicate-posts/ (or similar). Switch to “All languages” in page list to confirm that there aren’t some ghosts/duplicates.

    Also, you can try to open https://wpml.org/documentation/support/wpml-troubleshooting-options/ and run “Clear the cache” and “Remove ghost entries” (first two buttons).

    Please check entire website after this… (Do all pages exist, content, …)

    I see that you have installed “glue” plugin, but it’s same (except hreflang relative links in header). Also, please contact WPML support if previous actions can’t help…

    Thread Starter jamesoh5

    (@jamesoh5)

    @stodorovic When I downloaded the “glue” plugin and tried to install it, it said it was an already installed plug. I assume that the “glue” plugin was included in the WPML integration file at the time of installation. However, I have completed the reinstallation.

    I also disabled the “Adjust IDs for multilingual functionality” option by entering the WPML setting as you said.

    I just checked and there is a critical error in WPML. There are a total of three categories of page items produced through WPML. They are “translated language”, “original language”, and “all languages”. If I connect to a page through the “translated” category, I will get a normal “ar” prefix, but if I connect through the “all languages” category, I will not get an “ar” prefix.

    In other words, it seems that the wrong page was created due to a WPML error.

    I left an inquiry on the wpml support page. link

    I am truly grateful for your help.

    Thread Starter jamesoh5

    (@jamesoh5)

    @stodorovic I just saw you leave a comment. I found the “ghost” page as you say. Thank you very much for your help. However, deleting this “ghost” page also deletes the original translated page. When deleted and restored again, the “ghost” page is restored as well.

    I ran all the way up to “clear cache” and “remove ghost entries”, but there is still a “ghost” page.

    The “bug report” of the wpml plugin shows that the time when the bug occurred and the “ghost” page was created are similar. I expect that the sitemap problem will be solved when the bug in wpml is resolved.

    If it is technically difficult to solve, we will just delete the page and start translating again.

    Thank you very much for spending your precious time on my problem. I hope you have a good day.

    Plugin Support Priscilla Chapman

    (@priscillamc)

    Hi @jamesoh5,

    Thanks for the updates and for posting the link to your issue with WPML. If you do test to see if deleting solves the sitemap issue, please let us know. We’ll leave this open for the next week just in case you have any new information to share.

    By the way, you should see that the “glue” plugin, WPML SEO, is installed and activated on your Plugins screen.

    Thread Starter jamesoh5

    (@jamesoh5)

    I solved the problem with the help of WPML supporters. I’m leaving a problem-solving process for those who might be of any help.

    WPML Support link

    1. All trouble shooting items mentioned by big supporters were clicked.

    >> On the Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

    – Clear the cache in WPML
    – Remove ghost entries from the translation tables
    – Fix element_type collation
    – Set language information
    – Fix WPML tables collation
    – Assign translation status to duplicated content
    – Fix terms count
    – Fix post type assignment
    – Cleanup and optimize string tables`

    2. Upon completion of the course, a page with incorrect language prefix was created separately.

    Prior to the end of this process, the normal page with language prefix and the error page without language prefix were linked together, so if I delete the wrong page, the normal page was deleted too.

    However, after finishing all the procedures of troubleshooting, pages with “ar” attached to the language prefix and pages without the language prefix were separated, and normal pages remained after clearing the error page.

    3. Afterwards, sitemap was also modified normally, leaving only valid pages.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Yoast sitemap generated invalid single page’ is closed to new replies.