Support » Plugin: Yoast SEO » Yoast. Shop page have no index error. How to solve the problem?

  • Resolved boppar

    (@boppar)


    Google search console gave a “no index” error on my shop page.

    My shop is located like:
    http://www.examplestore.se

    It seems like Woocommerce have a default page:
    http://www.examplestore.se/shop

    Actually I never paid any attention to this page and didn’t know it existed.
    It’s marked like private.

    I don’t understand how Google can crawl that page if it’s marked as private?
    To get rid of the error, should I in the Yoast fields just select “No” on “Should search engines follow links on this Page”?

    Is it a better solution to delete that page or should I leave it in Woocommerce even though I don’t use that page?

    • This topic was modified 1 year, 4 months ago by boppar.
Viewing 4 replies - 1 through 4 (of 4 total)
  • dont delete your shop page you will destroy your woocommerce structure. the shop page is supposed to be nonindex but dofollow

    Thread Starter boppar

    (@boppar)

    @livingeasylivecom
    Hi.
    OK, I won’t delete the shop page.

    You wrote that the shop page is supposed to be nonindex but dofollow.

    I’m a little bit confused.
    “Allow search engines to show this post in the search results?”
    should it be set to “Yes” or “No”???

    I read this thread:
    https://wordpress.org/support/topic/woo-shop-page-post-is-set-to-no-index/
    It says the setting should be “Yes”.
    https://imgur.com/a/dBak6jy

    In this article it says the shop page should be indexed.
    https://businessbloomer.com/noindex-woocommerce-product-tag-pages/

    To get me even more confused. Here it says If you don’t want to noindex an individual post, set the setting ‘Allow search engines to show this post in the search results?’ to ‘No’.
    https://yoast.com/help/how-do-i-noindex-urls/
    As I understand, if you set it to “Yes” the search engine will show the page in the search results, that is it will be indexed. But what it says in the article is the opposite.

    What part is I understanding the wrong way?

    Plugin Support devnihil

    (@devnihil)

    @boppar Regarding your question of: “Allow search engines to show this post in the search results?” should it be set to “Yes” or “No”?

    If you want to set the shop page to NOT be indexed in Google’s search results, you would set this value to ‘No.’ If you do want it to be indexed in Google’s search results, you would set this value to ‘Yes.’

    Typically you would have the Shop page of your WooCommerce site to be able to be indexed, so the value for “Allow search engines to show this post in the search results?” would be set to ‘Yes.’

    Thread Starter boppar

    (@boppar)

    @devnihil
    Thanks, devnihil!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Yoast. Shop page have no index error. How to solve the problem?’ is closed to new replies.