Support » Plugin: wpForo Forum » Yoast SEO + WP Foro

  • Resolved fahadurrehmankhan1

    (@fahadurrehmankhan1)


    Hi, my wp foro threads are not getting indexed on google. Tell me the best settings for SEO yoast to work best with WP Foro.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author gVectors Team

    (@gvectors-team)

    For wpForo the best option is the built-in wpForo SEO system. It’s already turned on and works fine. You have a few forums and topics. All those are already indexed: https://www.google.com/search?q=site:www.digitalphablet.com/forums/

    However you should also add the forum sitemap in your website Google Webmaster tool. Here is your forum sitemap. I hope you have a Google Webmaster Tool for this website, and you can submit the forum sitemap.

    Your forum sitemap URL is this:

    https://www.digitalphablet.com/forums/sitemap.xml
    
    • This reply was modified 4 months, 2 weeks ago by  gVectors Team.
    • This reply was modified 4 months, 2 weeks ago by  gVectors Team.

    This is the best reply to my query. Just one last thing, there are three things in forums which are getting indexed “Profile”, “Tags” and “Topics”

    I only want “Topics” to be indexed, I don’t want Profiles or Tags to be indexed.

    And also i am getting a lot of “Spam” sign ups

    Plugin Author gVectors Team

    (@gvectors-team)

    I only want “Topics” to be indexed, I don’t want Profiles or Tags to be indexed.

    Thank you @fahadurrehmankhan1 You can disable profile indexing in Dashboard > Forums > Settings > Features admin page, just set "No" the "Enable User Profile Page indexing" option.

    To disable tags indexing, navigate to Dashboard > Forums > Tools > Misc Tab and put this URL in “Noindex forum page URLs:” textarea:

    https://www.digitalphablet.com/?wpfin=tag*
    

    And also i am getting a lot of “Spam” sign ups

    You’re not alone. 99% of website get tons of spam signup per day, and this is not wpForo issue, this is signup form protection issue. I see the signup page is not wpForo page, you use other plugin (probably UM) for signup so please ask this plugin support team how to protect that form, as far as I know they have reCAPTCHA addon for free.
    If you use wpForo registration form you should configure built-in reCAPTCHA in Dashboard > Forums > Settings > Tools > Antispam Tab. This will decrease spam signups. Also I recommend install Akismet, it’s well integrated with wpForo. Here is an example of wpForo signup page with protected reCAPTCHA: https://wpforo.com/community/?wpforo=signup

    • This reply was modified 4 months, 2 weeks ago by  gVectors Team.

    And, the people who started the threads are not getting email notifications when someone is replying to their threads.

    Plugin Author gVectors Team

    (@gvectors-team)

    Maybe emails are in spam-boxes, or they have not subscribed or they have not confirmed their subscriptions via email. There are dozens of reasons….

    Please check all these point, in 99% cases this is admin configuration or user subscription mistakes: https://wpforo.com/community/faq/not-receiving-automatic-replynotificationconfirmation-emails/#post-5344

    Thanks a ton, you guys have been a great help. Thanks! I just reviewed you 5/5.

    Plugin Author gVectors Team

    (@gvectors-team)

    Great! Thank you very much.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.