Support » Plugin: Yoast SEO » Yoast SEO was unable to create the database tables required and as such will not

  • Resolved albie2011

    (@albie2011)


    Updated to WP SEO 14.0 and received this error in dashboard:

    “Yoast SEO was unable to create the database tables required and as such will not function correctly.”

    Never had a problem before upgrading Yoast so not sure this is a hosting issue.\

    Any ideas?

    The page I need help with: [log in to see the link]

Viewing 15 replies - 46 through 60 (of 75 total)
  • what a ridiculous comment posted on yoast website…

    If you hosting provider is unwilling or unable to change these permissions for your website, we really only have on piece of advice: get a different host. We have a long list of large and reputable WordPress hosting companies with whom we have great relations that you won’t have this problem with.

    unhelpful, nonsense. How about another piece of advise.

    uninstall yoast!!

    lots of people suffering problems and rather than troubleshoot problems properly (or test before releasing) they blame others … the arrogance of it.

    webgeeze (@webgeeze) totally agree. I don’t want to make changes to my database which could cause other issues. So I’ll switch back to AIO. Sorry, but I don’t have the time to tinker around code based problems.

    @webgeeze and @meydot, what are your thoughts on SEOPress

    wpgiftshava (@wpgiftshava) I don’t know it. Most of my sites are using AIO. Only 2 multisites are using Yoast and I will change them to AIO like my others.

    Gotchu @meydot

    Need not to stress my self with coding now. Had to simply roll back to version yoast 13.5 straight with WP Rollback plugin

    I switched 1 site back to AIO and gave v14.0.3 a try on the other site. Now it seems to work. The indexing process can be started separately. I tried this too and it works.

    Same issue “Yoast SEO was unable to create the database tables required and as such will not function correctly.”

    I have updated from version 14.2 to 14.0.4 on number of sites and some show the error while other don’t. All dbs are working correctly and running WP 5.4.1 and PHP 7.3.

    On the sites without the error Yoast SEO has offered to “speed up the site / optimized” – is this related?

    Any thoughts or suggestions?

    To me happened after i deleted 4 tables related to Yoast, but have left 2 which have Index names, then i installed last version and the message was displayed.

    Hey, same problem here.. Any new suggetions?

    @abiox
    Check on previous pages, you will need to install another Yoast plugin to reset some database tables, which worked for me.

    I tried the roll back steps in the post on page 3… but did not remove the error for me.

    I have “utf8mbf_danish_ci” on all my (Norwegian/Dansih) sites, and this causes exact same error. Strange! Changed to “utf8mb4_unicode_ci” and it immediately wanted to upgrade, and it worked.

    “utf8mbf_danish_ci” is a perfectly legal collation. Why does this cause an error?

    I run a VPS for my websites. Tried all the mentioned methods to fix this particular issue. The only method that sort of works for me was to rollback to v13.5 for now. Will wait for a working update until then.

    Also have this issue.
    Rollback to 13.5 caused a fatal error:

    Report:

    
    WordPress version 5.4.1
    Current theme: Cool Earth (version 1.1.1)
    Current plugin: Yoast SEO (version 13.5)
    PHP version 7.2.24-0ubuntu0.18.04.4
    
    Error Details
    =============
    An error of type E_ERROR was caused in line 25 of the file /.../src/wp-content/plugins/wordpress-seo/admin/class-primary-term-admin.php. Error message: Uncaught Error: Class 'WPSEO_Frontend_Primary_Category' not found in /.../src/wp-content/plugins/wordpress-seo/admin/class-primary-term-admin.php:25
    Stack trace:
    #0 /.../src/wp-content/plugins/wordpress-seo/admin/class-admin.php(125): WPSEO_Primary_Term_Admin->register_hooks()
    #1 /.../src/wp-content/plugins/wordpress-seo/admin/class-admin-init.php(31): WPSEO_Admin->__construct()
    #2 /.../src/wp-content/plugins/wordpress-seo/wp-seo-main.php(410): WPSEO_Admin_Init->__construct()
    #3 /.../src/wp-includes/class-wp-hook.php(287): wpseo_admin_init('')
    #4 /.../src/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters(NULL, Array)
    #5 /.../src/wp-includes/plugin.php(478): WP_Hook->do_action(Array)
    #6 /.../src/wp-settings.php(403): do_action('plugins_loaded')
    #7 /.../src/wp-config.php(191): require_once('/home/co
    
Viewing 15 replies - 46 through 60 (of 75 total)
  • The topic ‘Yoast SEO was unable to create the database tables required and as such will not’ is closed to new replies.