Support » Plugin: Yoast SEO » Yoast SEO was unable to create the database tables required and as such will not

  • Resolved sirrahikkala

    (@sirrahikkala)


    As the support has stated elsewhere, I will start a new topic with the issue. Latest version of Yoast at the time of writing, 14.0.4.

    I have 3 almost identical (different languages) sites within same server instance which all use same database but with their own table prefixes. Just this one site is experiencing issues with database creation. This leads to question why is Yoast suggesting to contact hosting to fix issue which is clearly more related to plugin than the database or the server setup?

Viewing 8 replies - 1 through 8 (of 8 total)
  • mellowvision

    (@mellowvision)

    I just updated and got the same error . 14.0.4

    Plugin Support Maybellyne

    (@maybellyne)

    Hello @sirrahikkala ,

    You are asked to contact your web hosting provider because for Yoast SEO to work, it needs to be able to create new tables in the database. Yoast SEO automatically tries to create these tables but may fail. Your web hosting provider will be able to fix the database permissions so the plugin can create those tables

    Hello @mellowvision
    If you still see the error with Yoast SEO 14.0.4, can you please try the following steps:

    • Install the Yoast Test Helper plugin, you can add it by going to Plugins > Add New > Search for ‘Yoast Test Helper’ – or download it https://wordpress.org/plugins/yoast-test-helper/.
    • Go to Tools > Yoast Test
    • Click the Reset indexables tables & migrations button.
    • Go to SEO > Tools and click the “Speed up my Site” button to let the indexation run
    • The reset button with the Help Test Plugin should recreate the necessary tables and then you can re-run the process.

    There is no “Speed Up my Site” button on my SEO>tools page.

    Plugin Support Maybellyne

    (@maybellyne)

    @mellowvision

    Can you please make a screenshot of your SEO > Tools page? Thanks

    Having gone through all of the steps suggested above, I have no “Speed up my Site” button either. We have a few sites hosted on Liquidweb (formerly Rackspace cloud). One updated immediately with no hiccups, but the other refuses. SEO>Tools now has the text link counter button, but no speed up site button. My next guess is a plugin conflict. Will try the site health troubleshooting tool next.

    Hate to be a noob, but I don’t see how to insert a screenshot in the WP forums? Copy/paste doesn’t seem to be an option here, so I’m assuming it must be hosted?

    • This reply was modified 5 months, 3 weeks ago by mbfmf.
    • This reply was modified 5 months, 3 weeks ago by mbfmf.

    Never mind. Update v14.1 adding the debug info in the error notification helped us track down the issue to a problem with the database collate setting in our wp-config.php file. It was simply an old default collate setting ‘latin1_swedish_ci’ which never got updated

    Plugin Support Carl B

    (@devnihil)

    @mbfmf Thanks for confirming you were able to resolve the error by adjusting your database’s collation setting.

    @sirrahikkala If you update to the most current version of Yoast SEO version 14.1, does this resolve the issue? You can learn more about updating here: https://kb.yoast.com/kb/how-can-i-update-my-free-plugin/

    Plugin Support Jeroen Rotty

    (@jeroenrotty)

    We are going ahead and marking this issue as resolved due to inactivity. If you require any further assistance please create a new issue. Thank you!

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.