Support » Plugin: Yoast SEO » Yoast SEO update causing issues – "Your homepage cannot be indexed by search en

  • Resolved TJayYay

    (@tjayyay)


    Help. I just updated Yoast SEO and am getting the same issues as so many others are reporting today. However, my error message, “Your homepage cannot be indexed by search engines” doesn’t get resolved by Fetching the current status. And while I have started the sign up at this new requirement Yoast SEO has created in this update, at OnPage, but don’t have any analysis yet – and I refuse to give them my personal details so they can benefit “commercially” as they clearly state.

    Is this really a problem that my homepage can’t be indexed by search engines, and just coincidentally popped up at this same time as this Yoast SEO update (?!) or is this (more likely) a plugin bug.

    And please do away with that external requirement. I hope you aren’t starting to ruing this great plugin.

    Thanks in advance

    https://wordpress.org/plugins/wordpress-seo/

Viewing 14 replies - 1 through 14 (of 14 total)
  • Same here.
    It looks like this feature hasn’t been thought through.

    After I refetched the current status I still get the same error message.
    I did, reluctantly, sign up to onPage.org.

    The information it gives is not very helpful.
    I think I saw a note to the effect that my homepage wasn’t being cached because of canonicalisation: http://compton.parish.hants.gov.uk/ is mapped to http://compton.parish.hants.gov.uk

    That error message (about canonicalisation) no longer appears, I can’t figure out how I set up that mapping (if I did), and I’m not really bothered if my home page isn’t indexed because it only contains the excerpts of the latest posts on my site.

    More worryingly, onPage reports a lot of 503 errors on my site.
    Could this be because Wordfence blocks suspiciously heavy users by returning error code 503?
    My Wordfence log shows the following shortly after I registered my site on onPage:
    [Nov 18 13:40:58] Throttling IP 78.46.43.18. Exceeded the maximum global requests per minute for crawlers or humans.
    [Nov 18 14:35:47] Blocking fake Googlebot at IP 74.125.18.225
    although the latter ip address appears to be owned by Google.

    Some of the new function (for example editable snippets) is very welcome, but if there’s an incompatibility between Yoast SEO and Wordfence I would retain Wordfence in preference to Yoast SEO.

    Hi Adrian,

    Thanks for sharing your experience with the latest Yoast SEO and with onPage. I use Wordfence also, it’s essential to me, as well. I hope we get a fast update on this Yoast SEO issue, to resolve these new issues. Otherwise, I will be looking around for a new SEO tool.

    Yeost have just released 3.0.2 and that appears to have fixed the bug.

    There is a 3.0.3 now, I am going to try it (Fingers crossed)

    No change – I still have the error message that my homepage cannot be indexed – blah! HELP

    And forcing your Yoast SEO users to go to a third party site and HAVE to give personal info to get the analysis is a joke.

    My affected site IS coming up in Google search results – so is this telling me the Yoast SEO/onpage error about it not being indexed is a bug?

    Latest version 3.0.4 STILL has this same problem.
    And why is there still not a response to help from Yoast SEO nor WordPress??

    I am getting the “Your homepage cannot be indexed by search engines.” message too and deactivating Sucuri and Wordfence on the site didn’t help…please help Yoast!

    Ok, I think it’s working on the site I saw the issue on. When I moved the site from a subfolder to the main folder, the Sucuri plugin didn’t fully move over. I switched to All in One SEO Pack and thought I was going to have to stick with that, but after fully removing Sucuri and readding / reactivating everything (including Sucuri / Wordfence), it’s not showing the message anymore. I love this Yoast plugin, but this was a hassle…hope everything’s resolved now. Thanks!

    I had the same problem, my site that was getting this message in the dashboard:

    “Your homepage cannot be indexed by search engines. This is very bad for SEO and should be fixed.”

    This message is actually from the WordPress SEO plugin by Yoast. I searched the forums and found several people who were getting the same issue, and who were able to rectify it by visiting the Yoast widget in the dashboard, and clicking the OnPage.org “Fetch again” button:

    https://wordpress.org/support/topic/updated-and-now-it-says-homepage-cant-be-indexed
    https://wordpress.org/support/topic/your-homepage-cannot-be-indexed-by-search-engines

    However, there are several people who were unable to clear the message, and I found myself in the same situation. I was about to write off the error as erroneous, when I decided to check the headers using several different tools on a couple of different sites. When I did, I discovered that the site was actually returning a 503 Internal Server Error to bots, and when I went through the access logs I realized that it was doing the same to Googlebot as well.

    I disabled all of the plugins and re-tested, and the error went away. I then re-enabled them all aside from Wordfence, and it stayed away, but as soon as I enabled Wordfence all of the bots, including Googlebot, were blocked again:

    74.125.18.224 – – [27/Nov/2015:00:21:06 -0600] “GET /robots.txt HTTP/1.1” 503 2438 “-” “-“
    74.125.18.224 – – [27/Nov/2015:00:21:06 -0600] “GET / HTTP/1.1” 503 2438 “-” “Googlebot/2.1 (+http://www.google.com/bot.html)”

    I verified with ARIN that those are indeed Google IP addresses. I have no idea why Wordfence has started blocking Google IP addresses, but this will kill your seo dead if it is happening to you. Also, there are 0 IPs showing in the “Blocked IP” list, so these appear to be blocked by default and not blocked due to bad behavior.

    After disabling Wordfence I was able to also successfully use the Fetch Again button in the Yoast SEO widget, and OnPage.org was able to verify that the site was visible.

    Problem fixed.I hope it works for you guys too.

    https://wordpress.org/plugins/wordfence/

    Thank you, alberto14 for saving us a lot of time. We use Wordfence religiously, and I’ve confirmed that disabling WordFence makes the message go away after another scan, and enabling it again makes the message return. Nice catch!

    Stacey

    (@pleasehelpme)

    I was having the same issue on all my sites. Have been pulling my hair out after trying all sorts of things.
    Thanks to alberto14, I directed my attention to Wordfence. I didn’t have to disable or remove it. Just changed the Wordfence security level setting from custom to Level 2 Medium. Now after fetching again, the homepage is indexable.

    Thank you alberto14! You saved the day!

    I’m going to pass this info on to Yoast and Wordfence.

    Great info Stacey. I would say though, go back in and adjust your number of login and password recovery attempts, and enter in your blocked usernames as well. Won’t affect it and keeps two big security features in place.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Yoast SEO update causing issues – "Your homepage cannot be indexed by search en’ is closed to new replies.