Support » Fixing WordPress » Yoast SEO Plugin Problems

  • My Yoast SEO Version 3.5 is not working properly on WordPress. Here are some screenshots.

    http://prnt.sc/cikij8

    http://prnt.sc/cikiyy

    I have rolled back the Plug upto 3.0 and still same problem. There is no parsing script and I have deactivated the caching plugin, but same problem. Earlier, when I used to enter the Focus Keyword, I used to see a green, orange or red button. Now, it all remains grey all the time.

    Is anyone having the same problem and can someone suggest how to fix this.

Viewing 11 replies - 1 through 11 (of 11 total)
  • i had the the same issue once but for 1 post . logged out then logged in and the problem was solved.

    hope that help.
    if not i think you need to mention your WordPress version.

    I have logged in and logged out, but, same problem

    WordPress Version is 4.6.1

    Sometimes strange behavior may be caused by a plugin or theme conflict. The fastest way to rule out conflicts is to deactivate all non-Yoast plugins and switch to a standard theme like Twenty Sixteen. If this resolves the issue, you have a conflict and should activate one plugin at a time until you locate the conflict. Finally, after all plugins are active, switch to your theme. This will narrow down the conflict to a specific plugin or theme.

    If you are unfamiliar with checking for conflicts, we wrote a small guide that will walk you through the steps. You can find it here: How To Check For Plugin Conflicts

    Thank you for the great advice. Seemingly a Plugin named iQ Block Country was conflicting with the Yoast Plugin. I am still wondering why iQ Block Country is blocking Wordfence.

    Thanks for your great advice and I consider this matter RESOLVED.

    I run Yoast Seo + WP 4.6.1 + iQ Block Country on my sites just fine. So that should not be the issue.

    Thanks Pascal. I tried to play around with the settings of iQ Block Country. I had every country except mine blocked from accessing the back end of the website.

    Just wondering if something is interfering with the Yoast Server. Perhaps, I need to add something in the safe list ?

    Hello,

    we deactivated all 24 plugins one by one and couldn’t get Yoast to work – we see the same behaviour as in the snapshots by OP. We run WP Version 4.6.1 and the latest Yoast version (= 3.5 at the time of writing).

    Is someone from Yoast looking into this?

    We’re starting to evaluate our options for moving from Yoast for this site. Any idea how not to lose all the meta work done on the (dozens of) posts?

    Good luck with Yoast, They will not respond till you pay the premium fees. On all my new websites, I do not use Yoast for this very reason.

    You should try and fix this issue before trying to switch. Here are some things I did :

    a) Check for any javascript parsing or caching script in function.php. Delete it to see if it works.

    b) Deactivate caching from hosting panel, if you have one and see it it works.

    c) Try rolling back the WordPress to a previous version.

    d) If you have country blocking or IP blocking, try and remove all blocks.

    e) Switch Themes to regular themes.

    Unfortunately, after scouting around for 3 months, I tried deactivating plugins and it worked.

    Lesson learnt, do not use Yoast free SEO as if you want to switch, the switching cost is very heavy.

    Tested three more websites with Yoast and iQ Block Country and WP 4.6.1. Yoast SEO starts conflicting with iQ Block Country.

    As soon as the same is uninstalled, Yoast starts working perfectly fine.

      error 500 unable to load page

    After I activated Yoast SEO, and OnPage plugins something went terribly wrong. I was able to get my site up & running again, but I can’t access WP control panel in order to edit my site. I keep getting suggestions to deactivate the plugins, but if I can’t access the control panel, I can’t do anything.

    I received this info from my webhost:

    [03-May-2017 16:05:03 UTC] PHP Fatal error: Class ‘WPSEO_OnPage’ not found in /home/angelict/public_html/wp-content/plugins/wordpress-seo/wp-seo-main.php on line 390

    [03-May-2017 16:10:03 UTC] PHP Warning: include(/home/angelict/public_html/wp-content/plugins/wordpress-seo/admin/onpage/class-onpage.php): failed to open stream: No such file or directory in /home/angelict/public_html/wp-content/plugins/wordpress-seo/vendor/composer/ClassLoader52.php on line 186

    [03-May-2017 16:10:03 UTC] PHP Warning: include(): Failed opening ‘/home/angelict/public_html/wp-content/plugins/wordpress-seo/admin/onpage/class-onpage.php’ for inclusion (include_path=’.:/opt/cpanel/ea-php56/root/usr/share/pear’) in /home/angelict/public_html/wp-content/plugins/wordpress-seo/vendor/composer/ClassLoader52.php on line 186

    [03-May-2017 16:10:03 UTC] PHP Fatal error: Class ‘WPSEO_OnPage’ not found in /home/angelict/public_html/wp-content/plugins/wordpress-seo/wp-seo-main.php on line 390

    Tech Support Team,
    Blue Bell Web Hosting, LLC

    Any help is greatly appreciated.

    Namasté

    You need to access the File Manager through your CPANEL, go to WP CONTENT/Plugins and change the name of Yoast SEO Plugin (add a digit after that or something else). Now, try to access your Dashboard after you clear your Browser Cache.

    If you still have the same problem, go back to File Manager and Change the Name of the Plugins Folder to something else, now, try again.

    If your site is still broken or you are still unable to log in to the dashboard, Manually update the WordPress Files. Take a backup before you do anything.

    http://www.wpbeginner.com/wp-tutorials/how-to-manually-update-wordpress-using-ftp/

    This should solve the problem.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Yoast SEO Plugin Problems’ is closed to new replies.