Support » Plugin: Yoast SEO » Yoast SEO Multilingual WPML – changed URL – data optimization does not complete

  • Resolved w-sky

    (@w-sky)


    Hello, we are having a problem with Yoast SEO in conjunction with the Yoast SEO Multilingual plugin and WPML on our Website chillisimo.de.

    We recently changed the URL scheme for the second language (English) from chillisimo.de/en to chillisimo.com and since then every day a notification from Yoast SEO comes up: “Because of a change in your home URL setting, some of your SEO data needs to be reprocessed.”

    Then I click on “Start SEO data optimization”, after a few seconds it says “SEO data optimization complete” but on the next day I am getting the message again.

    Using the latest WordPress version and plugins. WP 5.5.3, Yoast 15.2.1, Yoast SEO Multilingual 1.2.4, WMPL 4.4.3, PHP 7.4.12, MySQL 5.7.32

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    We are sorry to hear you are having trouble with our plugin. We totally understand how that could be frustrating for you. Let’s see what’s going on here.

    To troubleshoot the issue further, we’d like you to please reset the Indexables tables and migrations by using the Yoast Test Helper plugin to see whether this resolves the issue for you.

    Install and activate the Yoast Test Helper plugin;

    • Go to Tools → Yoast Test → Yoast SEO → Reset indexables tables & migrations options to reset it;
    • Run the SEO data optimization from the SEO → Tools page again to see whether this resolves the issue for you;

    Can you please confirm whether the issue persists performing the above steps?

    Plugin Support devnihil

    (@devnihil)

    We are going ahead and marking this issue as resolved due to inactivity. If you require any further assistance please create a new issue.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Yoast SEO Multilingual WPML – changed URL – data optimization does not complete’ is closed to new replies.