Support » Plugin: Yoast SEO » Yoast SEO incompatibility with Divi theme

  • Resolved webupdates2

    (@webupdates2)


    I was wondering if you could tell me if there are known compatibility issues between the Divi theme and Yoast SEO version 19.3? IYoast has recently stopped working on all of our Divi sites.

    Yoast version 19.3
    Divi theme version of 4.17.6
    WordPress 5.9.3 running Divi Child theme

    Thank you.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Just to add to this, I’ve noticed that since 19.3, the Flesch reading ease test doesn’t seem to work with Divi. I get “The copy scores 0 in the test, which is considered very difficult to read” on all pages.

    To test this, I setup a brand new site (WP 6.01, Yoast 19.3 upgraded to 19.4, PHP 7.4) with no other plugins installed but I still got the “copy scores 0” message after adding dummy content.

    I haven’t noticed any other issues with Yoast and Divi.

    Plugin Support Maybellyne

    (@maybellyne)

    Hello All,

    We’re sorry to say that, at the moment, Yoast is not fully integrated with Divi. This means that sometimes, Yoast SEO will say you don’t have something when you actually added it. This is because Yoast cannot read and parse all the Divi modules, where the compatibility issue mostly lies.

    In the past, we have tried to parse shortcodes and other content boxes with inferior results. Therefore, we opted to provide plugin and theme developers with an API that they can use to pass their content to our page analysis.

    So, if when performing the Yoast readability analysis, you realize that there are discrepancies, this would be purely a compatibility issue we do have a workaround for you, and these are the steps:

    1. Add your content with the Divi builder editor
    2. Save it as a draft and close the page/post
    3. Open the page/post using the default editor,
    4. Check for the plugin advice, adjust your text, save, and then switch to your page builder.

    In addition, we also have good news, which is that we are currently improving our compatibility with Divi. We don’t have an ETA though when it will be implemented, but it will improve in the future.

    Thanks Maybellyne. I’ll try the workaround for the readability analysis. Full compatibility with Divi builder would be great, so I look forward to that.

    Plugin Support devnihil

    (@devnihil)

    @woopee We are going ahead and marking this issue as resolved due to inactivity. But if you require any further assistance please let us know.

    @devnihil That’s fine with me but I’m not the OP. I just added a comment.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.