Support » Plugin: Yoast SEO » Yoast SEO had problems creating the database tables needed to speed up your site

  • Resolved sdghosh

    (@sdghosh)


    Hello,

    I have this error showing up on top of my WordPress admin control panel.

    “Yoast SEO had problems creating the database tables needed to speed up your site. Please read this help article to find out how to resolve this problem. Your site will continue to work normally, but won’t take full advantage of Yoast SEO.
    Show debug information
    ResetIndexableHierarchyTable – Error executing ‘query’ with: TRUNCATE TABLE wp_yoast_indexable_hierarchy Reason: Table ‘bitnami_wordpress.wp_yoast_indexable_hierarchy’ doesn’t exist ”

    I am using Bitnami WordPress in Google Cloud. I am a novice.

    Any help will be appreciated.

    Kind regards,

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    We are sorry to see that you’re having an issue with the Yoast SEO Plugin and we’d be happy to assist you further on this.

    This issue typically occurs when the Yoast SEO cannot reset the indexables analysis related tables as one of the table bitnami_wordpress.wp_yoast_indexable_hierarchy seem doesn’t exist yet. Therefore, you’ll need to reset Yoast SEO indexables tables & migrations by using the Yoast Test Helper plugin.

    This can help you test our plugins on your staging environment and as well as for troubleshooting a feature in our plugin.
    – Go to Tools → Yoast Test → Yoast SEO → Reset indexables tables & migrations options to reset it.
    – Rerun the indexables analysis from the Yoast SEO → Tools → SEO Data → Start processing and speed up your site now option.

    Please let us know whether the issue persists after resetting the Yoast SEO indexables tables & migrations.

    waqashussain

    (@waqashussain)

    Yoast SEO had problems creating the database tables needed to speed up your site.

    Please read this help article to find out how to resolve this problem.

    Your site will continue to work normally, but won’t take full advantage of Yoast SEO.

    Show debug information
    WpYoastIndexable – Error executing ‘query’ with: CREATE TABLE wp_yoast_indexable ( id int(11) UNSIGNED auto_increment NOT NULL, permalink mediumtext, permalink_hash varchar(191), object_id int(11) UNSIGNED, object_type varchar(32) NOT NULL, object_sub_type varchar(32), author_id int(11) UNSIGNED, post_parent int(11) UNSIGNED, title varchar(191), description text, breadcrumb_title varchar(191), post_status varchar(191), is_public tinyint(1), is_protected tinyint(1) DEFAULT ‘0’, has_public_posts tinyint(1), number_of_pages int(11) UNSIGNED, canonical mediumtext, primary_focus_keyword varchar(191), primary_focus_keyword_score int(3), readability_score int(3), is_cornerstone tinyint(1) DEFAULT ‘0’, is_robots_noindex tinyint(1) DEFAULT ‘0’, is_robots_nofollow tinyint(1) DEFAULT ‘0’, is_robots_noarchive tinyint(1) DEFAULT ‘0’, is_robots_noimageindex tinyint(1) DEFAULT ‘0’, is_robots_nosnippet tinyint(1) DEFAULT ‘0’, twitter_title varchar(191), twitter_image mediumtext, twitter_description mediumtext, twitter_image_id varchar(191), twitter_image_source varchar(191), open_graph_title varchar(191), open_graph_description mediumtext, open_graph_image mediumtext, open_graph_image_id varchar(191), open_graph_image_source varchar(191), open_graph_image_meta text, link_count int(11), incoming_link_count int(11), prominent_words_version int(11) UNSIGNED, PRIMARY KEY (id)) DEFAULT CHARSET=utf8; Reason: Table ‘wp_yoast_indexable’ already exists

    having this error how to solve it ???

    Plugin Support amboutwe

    (@amboutwe)

    @waqashussain If you have a similar issue, please open a new request. That way it’s easier to track issues and provide assistance. Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Yoast SEO had problems creating the database tables needed to speed up your site’ is closed to new replies.