Support » Plugin: Yoast SEO » Yoast SEO generates link errors in my home page

  • Resolved Dario Banfi

    (@thefreelance)


    Hi,
    Yoast SEO Plugin generates by default this code in the home page of my site:

    <link rel='dns-prefetch' href='//www.youtube.com' />
    <link rel='dns-prefetch' href='//secure-a.vimeocdn.com' />
    <link rel='dns-prefetch' href='//fonts.googleapis.com' />
    <link rel='dns-prefetch' href='//s.w.org' /> 

    If you check the source, using a normal link checker like https://validator.w3.org/checklink, you will find three errors:
    – Fonts Google Api’s URL isn’t correct
    – Vimeo secure cdn URL doesn’t work
    – Youtube link redirects to secure Url https://..

    Is There any way to exclude this code from my home page, please?
    Thank you very much for answering.

Viewing 1 replies (of 1 total)
  • Plugin Support amboutwe

    (@amboutwe)

    I did a quick search of our code and didn’t immediately find this output. I did see that the fonts and s.w.org are added by WordPress core. If you want to remove the core links, this topic has information about how to do it.

    The other two are likely added by another plugin or your theme. Please disable all plugins and switch to a default theme. Activate your theme and check your source code. If your theme outputs either of the links, please reach out to their support team for assistance removing them. If your theme doesn’t output the links, please enable Yoast SEO and check the source code to confirm that our plugin is not adding them. Then enable one plugin at a time to find the one that adds them.

Viewing 1 replies (of 1 total)
  • The topic ‘Yoast SEO generates link errors in my home page’ is closed to new replies.