Support » Plugin: Yoast SEO » Yoast SEO Disables Visual Composer Module Functionality

  • Resolved gcordero

    (@gcordero)


    Hi
    I have noticed that YOAST SEO don’t allow the links of the “authors” module in the column in the right of main page. The module (“Columnistas”) in this column corresponds to a Visual Composer module that shows “authors” of articles in a list.
    When you click on an author, the link seems to work but stays on the same page.
    I have tried disabling all the plugins, but it’s only YOAST SEO produces the problem.
    At the moment I have disabled YOAST for the column to work, but I do not know what to do.
    I need YOAST SEO, I think it has been a great help in many things, but I also need the links in the author’s column.

    What I can do? How could I solve the error?

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Pcosta88

    (@pcosta88)

    Hi,

    We would like some more information.

    • Can you elaborate more on what you mean when you say “When you click on an author, the link seems to work but stays on the same page.”?
    • Can you take screenshots of the issue? Note, you may need to add them via an image sharing tool like http://pasteboard.co/ and then copy/paste the url.
    • Can you confirm you are using the most recent Visual Composer?
    • Can you confirm you are using the most recent Yoast SEO v5.4? 
    • Can you confirm you are using WordPress 4.8.1? You can check by clicking on the W in the top left and selecting About. If you need to update, please check with your host provider. Please know that if you are using an older version of WordPress Core you may experience unexpected behavior with Yoast. This guide explains more: https://yoast.com/why-we-dont-support-old-wordpress-versions/.
    • This reply was modified 2 years, 4 months ago by Pcosta88.

    Hi! thank you very much for your answer.
    The comments are:
    > When I say “When you click on an author, the link seems to work but stays on the same page.”, it means that the link does not lead anywhere, but sees that it looks for the route and does not find it. The links are not working.

    > Here are the screenshot of the link that don’t work.
    https://pasteboard.co/GK3ysWp.jpg
    If I disable Yoast SEO in administrator, the links works and takes me to the articles of that author.

    > Here are a screenshot of the WP version, Visual Composer and Yoast SEO version. All of them are the last version. https://pasteboard.co/GK3xXeT.png

    Any incompatibility? Where can I search? http://chilecientifico.com/

    Thank!

    Plugin Support marcanor

    (@marcanor)

    Hello,
    Is the Authors moduke you mention a special module in Visual Composer? Or is it a standard Raw HTML or some other block? Standard Raw HTML blocks are expected to work properly.
    If you disable all other plugins and leave only Yoast and VC active, does the issue resolve?

    Hi
    The author’s module is a author’s standard box
    https://pasteboard.co/GL001uI.png
    https://pasteboard.co/GL00fBj.png
    I have unpublished all the plugins and then I have activated only Visual Composer and Yoast Seo plugins.
    The authors column does not work.
    Now I have re-posted the other plugins and I have deactivated Yoast Seo, but really I need Yoast Seo.
    Do you have some idea?

    Plugin Support monbauza

    (@monbauza)

    Can you please go to “SEO > Titles & Metas > Archives” and make sure Author Archives are enabled on your website? Please, refer to this KB articles for more information: https://kb.yoast.com/kb/disable-enable-author-archives/

    This was all…!!
    Thank you very, very much…! this took me too long time!
    Thank you again..!

    Plugin Support Pcosta88

    (@pcosta88)

    We are glad the issue is resolved.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Yoast SEO Disables Visual Composer Module Functionality’ is closed to new replies.