Support » Plugin: Yoast SEO » Yoast SEO causing translated pages turn to 404s

  • Resolved CB


    Yoast and WPML together result in an issue where translated pages’ URLs disappear and become 404s.

    Before the Yoast 7.6 update, I’d get 404s for my translated pages every time I changed any settings on Yoast SEO and hit the save button. I’d then have to immediately go to Dashboard >> Settings >> Permalinks and hit the save button. Somehow this would bring the URLs for the translated pages back on.

    After the Yoast SEO 7.6 update, my website would start turning all translated pages into 404 unless I was logged in. After I logged out, a few minutes (or hours, perhaps a cache thing…) later I’d start getting alerts about 404s for the traslated pages. Then the second I logged in, my 404s ceased and URLs returned to normal (without the need to go to reset the Permalinks as mentioned above). The issue disappeared after I rolled Yoast SEO back to its last version before the 7.6 update, but the general issue of Yoast SEO making my translated pages URLs disappear after I change anything in the settings remain.

Viewing 1 replies (of 1 total)
  • I just got an alert that my translated pages URLs stopped working briefly, so something else (besides Yoast SEO update to 7.6) may be at play here. I will revert back to a backup of my website to where it was before this current series of 404s started, and try to troubleshoot the issue again.

    • This reply was modified 9 months, 1 week ago by  CB.
Viewing 1 replies (of 1 total)
  • The topic ‘Yoast SEO causing translated pages turn to 404s’ is closed to new replies.