Support » Plugin: Yoast SEO » Yoast SEO and Phlox free theme white screen on posts page

  • Resolved Tim de Hoog

    (@tim_nl)


    I use the latest version of Yoast SEO and the free Phlox theme.

    But when i visit the page with a overview of blogs no blogs are showed. The rest of the website loads just fine.

    I don’t get any error in the error log.

    WordPress 4.9.7
    Yoast SEO 7.8

    I use SiteOrigin Page Builder to style the page.

    • This topic was modified 3 years, 4 months ago by Tim de Hoog. Reason: Added some details
Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support devnihil

    (@devnihil)

    This could also be caused by a plugin or theme conflict. Can you try and gather as much information for us as possible? Please perform the following:
    1. Make sure the issue doesn’t persist when Yoast SEO is disabled.
    2. Check for conflicts.
    3. Check for JavaScript errors with your console.
    If you find any JavaScript errors related to Yoast SEO or if there is a conflict with a plugin or a theme, you can create a new GitHub issue for our developers. Please report the issue to a third party developer as well.
    If you didn’t find any conflicts or errors, we think the issue is specific to your site. We’d need to investigate further but are unable to do so on these forums. You can purchase Yoast SEO Premium and receive our Premium email support and we can help you further.

    Plugin Support devnihil

    (@devnihil)

    This could also be caused by a plugin or theme conflict. Can you try and gather as much information for us as possible? Please perform the following:
    1. Make sure the issue doesn’t persist when Yoast SEO is disabled.
    2. Check for conflicts.
    3. Check for JavaScript errors with your console.
    If you find any JavaScript errors related to Yoast SEO or if there is a conflict with a plugin or a theme, you can create a new GitHub issue for our developers. Please report the issue to a third party developer as well.
    If you didn’t find any conflicts or errors, we think the issue is specific to your site. We’d need to investigate further but are unable to do so on these forums. You can purchase Yoast SEO Premium and receive our Premium email support and we can help you further.

    Thread Starter Tim de Hoog

    (@tim_nl)

    1. The issue is gone when Yoast SEO is disabled.
    2. I will check this later today.
    3. No Javascript errors are showed.

    Plugin Support Michael Tina

    (@mikes41720)

    We’re not familiar with the overview of blogs. Do you mean the Yoast SEO posts overview widget? Or is this a special overview of blogs from the Phlox theme or SiteOrigin page builder? Or do you mean the list of all posts? If you could provide us a screenshot of your issue, this would help so we could provide more feedback.

    Thread Starter Tim de Hoog

    (@tim_nl)

    We’re not familiar with the overview of blogs. Do you mean the Yoast SEO posts overview widget?

    > No the default WordPress posts page. You can set the front page of WordPress to show a list of posts or you can set another page to show a list of posts.

    Or is this a special overview of blogs from the Phlox theme or SiteOrigin page builder?

    > No, it is possible to use the SiteOrigin page builder but even when I use the default page of WordPress for showing an overview the problem occurs.

    Or do you mean the list of all posts?

    > Yes

    If you could provide us a screenshot of your issue, this would help so we could provide more feedback.

    > A screenshot will show a blank white place where normally posts are shown.

    Thread Starter Tim de Hoog

    (@tim_nl)

    I have installed the Health check plugin and with your plugin enabled and others disabled the problem occurs. When your plugin is disabled the plugin doesn’t occur.

    But I don’t get any error in the log or console. The HTML is not rendered.

    Thread Starter Tim de Hoog

    (@tim_nl)

    I have found the problem and the solution.

    In /themes/phlox/index.php you will find this code snippet row 2:

    if ( have_posts() ) {
       if ( ! function_exists( 'elementor_theme_do_location' ) || ! elementor_theme_do_location( 'archive' ) ) {
         get_template_part( 'templates/theme-parts/loop', get_post_type() );
       }
    }
    

    When you activate YoastSEO the value of get_post_type() will become ‘page’. When you disable the plugin it will be ‘post’. ‘Post’ is the correct value.

    Is this a problem that must be solved in Yoast SEO or Phlox theme?

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    While we are unable to confirm whether this is an issue specific to the theme or Yoast SEO, we recommend you to submit a bug report here with all the details and share the report with the theme developer too so we both can investigate this issue further.

    Thread Starter Tim de Hoog

    (@tim_nl)

    I have started a support topic on the forum of the theme:
    https://wordpress.org/support/topic/no-overview-of-posts-when-yoast-seo-is-enabled/

    If they think that it is a Yoast SEO problem then I will create an issue on your GitHub page.

    I have fixed the bug by changing the index.php file in my own child theme.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Yoast SEO and Phlox free theme white screen on posts page’ is closed to new replies.