• Resolved luismoyano

    (@luismoyano)


    Hi there,

    I’m removing the trailing slash for all my posts, pages, and categories in permalink Lite preferences. However, Yoast SEO is still adding the last slash to all my categories, so Google tells me I must use a canonical URL. I fixed the canonical category on each, but Yoast is still adding that trailing slash.

    What’s the problem?

    Should I buy The Permalink Pro version to be able to fix this?

    Thanks ahead!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Maciej Bis

    (@mbis)

    Hi @luismoyano,

    Could you check if the issue persists after the sitemap cache is flushed?
    https://yoast.com/help/sitemap-does-not-update/#manual

    Thread Starter luismoyano

    (@luismoyano)

    I’ll try and let you know! Thanks!

    Thread Starter luismoyano

    (@luismoyano)

    Hi, I can confirm that deleting the Sitemap Yoast cache does not fix the issue.

    You can check my category sitemap online here in this image: https://ibb.co/31X04Q1

    I’m using the plugin “Permalink Manager Lite,” and the categories are working perfectly on the website without adding the last slash to the URL. But, the category sitemap still shows that slash, so Google tells me that my Sitemap is not showing the canonical URL in the Sitemap.

    How can I fix this? Manually? Should I delete the Yoast category Sitemap and add my own Sitemap for categories? Let me know!

    Thanks ahead!

    Moderator Support Moderator

    (@moderator)

    @luismoyano Please do not create duplicate topics again. Your new topic was archived.

    Plugin Author Maciej Bis

    (@mbis)

    Hi @luismoyano,

    Could you try to check if the issue persists also after Permalink Manager is deactivated? Just in case, you can also remove the trailing slashes using the built-in settings:

    https://permalinkmanager.pro/docs/plugin-settings/how-to-add-remove-trailing-slashes/#5-how-to-remove-trailing-slashes

    Thread Starter luismoyano

    (@luismoyano)

    Hi Maciej,

    First, sorry to duplicate the case. But I thought I had written my previous post on the Yoast SEO WordPress page in case the problem was theirs, hahaha. That’s why I wrote another post on this support page, looking for your help as the developer of Permalink Manager.

    OMG! I do so many things at the same time lately!

    The good news is that the problem has been fixed after removing the last slash within the WordPress permanent structures. I honestly thought that the Permalink Manager settings overwrote those default WordPress settings, and there was no need for me to do anything there.

    Now I see my mistake, and once I removed the last slash, the sitemap turned totally correct.

    Thank you very much for responding so quickly, and again, sorry for having duplicated the query by mistake.

    Have a nice rest of the week, and congrats for such a great plugin!

    • This reply was modified 2 weeks, 3 days ago by luismoyano.
Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.