Support » Plugin: Yoast SEO » Yoast SEO 15.8 incompatible with WC 5.0

  • Resolved tvillingforalder

    (@tvillingforalder)


    Just updated to WooCommerce 5.0.0 and both orders (detailed page) and products (detailed page) in admin area went blank (All input information, the template itself is still showing).
    Turns out that it’s Yoast that causes this. When deactivating Yoast SEO 15.8 everything works as it should. When activating the plugin, it turns blank again.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    We are sorry to hear that you’re having trouble with our plugin. Can you please check the server error log to see if you are seeing any errors from today’s date? If yes, please share the relevant errors here with us so that we can understand the issue better.

    However, if you’re seeing an error in the blank screens, you can share it here with us as well.

    We look forward to hearing from you.

    Same here… sites turns blank! Please try to solve it. It is affecting many sites we manage. We had to rollback to previous version to make the sites available again

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    @djwilko12 we are sorry to hear that you’re also experiencing the same issue. If you’d like us to investigate the issue further for you, please open a new topic on this forum. That way, it’s easier to track issues and provide assistance without alerting someone else for your problems and debugging, when they don’t need it.

    Hi
    But this topic is related with the original one. That is why i replied here. After your latest release, it broke our sites. Thanks and hope you can find a solution

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    @djwilko12 We appreciate you for letting us know that you’re experiencing the same issue. It’s completely fine if you want us to inform you here about the same issue. We only requested you to open a new topic if you’d like us to investigate the issue further for you as well. Otherwise, it’s completely fine!

    Thread Starter tvillingforalder

    (@tvillingforalder)

    Where would I find the error log?

    Thread Starter tvillingforalder

    (@tvillingforalder)

    Here’s a screenshot with Yoast activated. https://snipboard.io/tyQ4B6.jpg
    And here is the same screenshot with Yoast deactivated. https://snipboard.io/YhWm1L.jpg

    Plugin Support devnihil

    (@devnihil)

    @tvillingforalder Thanks for your reply. We’ve identified several concerns in your message and responded to each below:

    Where would I find the error log?

    This can vary depending on your server type and provider. So if you aren’t sure we’d recommend contacting your web hosting provider. However, many hosting providers allow you to access this log from a feature on the hosting control panel.

    Here’s a screenshot with Yoast activated/And here is the same screenshot with Yoast deactivated.

    Unfortunately we weren’t able to replicate this issue using Yoast SEO 15.8 and WooCommerce 5.0. From the screenshots though it does look like you are using the Classic Editor plugin, is that correct? If so, can you please ensure that the Classic Editor is using the most current version (Version 1.6) and also ensure that all of your other plugins/themes are up to date as well?

    Thread Starter tvillingforalder

    (@tvillingforalder)

    All plugins are up to date (I use auto-update).
    The only editor plugin I have are WP Edit, and deactivating this won’t fix the issue.

    The Webhost don’t have an errorlogs provided for free (by login to controlpanel or file on server), this is a service you have to pay for.
    The only only thing that is free is WP_DEBUG in WP-Config, wich is set to true, but there are no debug files.

    Plugin Support Pcosta88

    (@pcosta88)

    Hi @tvillingforalder,

    We are not able to reproduce this issue with v15.8 of Yoast and WooCommerce v5.0 using a default them like Storefront v3.5 using WordPress v5.6.1. The product page loads the information as expected and does not show a blank editor area.

    If all your themes, plugins and WordPress Core are updated and the issue continues to happen we suggest the following actions:

    1. Please Check for conflicts. Install the Healthcheck plugin and enable troubleshooting. Then switch to a standard theme like 2020/2021/Storefront etc. Does the issue resolve? NOTE: This will not affect how users see your site.

    2. Check for JavaScript errors with your console.

    If you find any JavaScript errors related to Yoast SEO or if there is a conflict with a plugin or a theme, you can create a new GitHub issue for our developers. Please report the issue to a third party developer as well.

    If you didn’t find any conflicts or errors, we think the issue is specific to your site. We’d need to investigate further but are unable to do so on these forums. You can purchase Yoast SEO Premium and receive our Premium email support and we can help you further.

    Thread Starter tvillingforalder

    (@tvillingforalder)

    The issue is NOT specific to my site since there are several tickets with the same issue. (Blank pages and “Auto-Draft”).
    The same issue applies on WP post and pages (not only on WC orders and products). Even when deactivating ALL plugins but Yoast.

    Plugin Support Pcosta88

    (@pcosta88)

    Hi @tvillingforalder,

    We understand there is a suspected issue with WooCommerce as well as on posts and pages. We know other users are experiencing a similar issue and can feel the frustration this is causing. However, we are unable to reproduce the issue.

    We have only two plugins active. See image: https://ibb.co/vqGMknN

    We are using storefront as the theme. See image: https://ibb.co/kSYX8pc

    We went to products and posts and the data still appears. This includes saving it as a draft or letting auto-save occur. See images: https://ibb.co/Jy5LfKQ and https://ibb.co/wJCPpCK.

    As we are unable to reproduce the issue we need your help.

    It is not clear to us if a complete conflict check or if errors were checked for. Can you confirm that both were done as described below?

    1. Please perform a full and complete conflict check. Install the Healthcheck plugin and enable troubleshooting. Then switch to a standard theme like 2020/2021/Storefront etc. Does the issue resolve? NOTE: This will not affect how users see your site.

    2. When the issue happens, please check for JavaScript errors. Do any appear on that page in the backend? They would appear in red in the console. Can you describe them or take a screenshot? If you are not sure how to look for JavaScript errors please use this guide https://yoast.com/help/how-to-find-javascript-errors-with-your-browsers-console/.

    You can use a tool like: https://imgbb.com/ to share the image.

    Please let us know the results of the conflict check and if any JavaScript errors appear.

    • This reply was modified 9 months, 2 weeks ago by Pcosta88.
    Plugin Support devnihil

    (@devnihil)

    We are going ahead and marking this issue as resolved due to inactivity. If you require any further assistance please create a new issue.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Yoast SEO 15.8 incompatible with WC 5.0’ is closed to new replies.