Support » Plugin: Yoast SEO » Yoast seems to crash the autosave

  • Resolved jdevreede

    (@jdevreede)


    It seems as if the Yoast plugin causes my WordPress to crash. This happens when I am editing blogposts and WordPress starts the autosafe. The autosafe fails and saving is not possible anymore.

    At the moment the save fails I receive an email from wordpress, which mentions:

    Sinds WordPress 5.2 is er een ingebouwde functie die herkent wanneer een plugin of thema een fatale fout veroorzaakt op je site en die je op de hoogte stelt met deze automatische e-mail. In dit geval heeft WordPress een probleem gevonden met één van je plugins: Yoast SEO.

    Foutdetails
    ===========
    Een fout van het type E_ERROR werd veroorzaakt op regelnummer 129 van het bestand /home/eetman1q/public_html/wp-content/plugins/wordpress-seo/src/memoizers/meta-tags-context-memoizer.php. Foutmelding: Uncaught TypeError: Argument 1 passed to Yoast\WP\SEO\Memoizers\Meta_Tags_Context_Memoizer::get() must be an instance of Yoast\WP\SEO\Models\Indexable, bool given, called in /home/eetman1q/public_html/wp-content/plugins/wordpress-seo/src/integrations/blocks/breadcrumbs-block.php on line 104 and defined in /home/eetman1q/public_html/wp-content/plugins/wordpress-seo/src/memoizers/meta-tags-context-memoizer.php:129
    Stack trace:
    #0 /home/eetman1q/public_html/wp-content/plugins/wordpress-seo/src/integrations/blocks/breadcrumbs-block.php(104): Yoast\WP\SEO\Memoizers\Meta_Tags_Context_Memoizer->get(false, 'Post_Type')
    #1 /home/eetman1q/public_html/wp-includes/class-wp-block.php(221): Yoast\WP\SEO\Integrations\Blocks\Breadcrumbs_Block->present(Array, '', Object(WP_Block))
    #2 /home/eetman1q/public_html/wp-includes/blocks.php(868): WP_Block->render()
    #3 /home/eetman1q/public_html/wp-includes/blocks.php(906): render_block(Array)
    #4 /home/eetman1q/public_html/wp-includes/class-wp-hook.php(303): do_blocks('

    A workaround I now use: deactivate Yoast, edit and save the article, activate Yoast again.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support Suwash Kunwar

    (@suascat_wp)

    @jdevreede

    This is most likely a WordPress update quirk. If you remove and reinstall the plugin, you should not have this issue anymore.

    Please clear all your caching from your theme, plugin, server, CDN like CloudFlare or browser. If you are not sure how to clear caching from theme/plugin please speak to those authors. If you want to clear cache from the server, please speak to your host provider. To clear the cache from a browser use this guide: https://kb.yoast.com/kb/how-to-clear-my-browsers-cache/.

    Thread Starter jdevreede

    (@jdevreede)

    Thanks, I just followed your advice and will monitor if it solved the issue. I’ll let you know if it helped.

    musicletter

    (@musicletter)

    I too have had the same problem for several days. Error that repeats itself.
    See here: https://wordpress.org/support/topic/from-now-i-have-a-serious-problem-with-yoast/

    Thread Starter jdevreede

    (@jdevreede)

    After clearing the caches from cloudflare, autoptimize, the browser and reinstalling Yoast, the error again happend while editing this page

    ERROR:

    WordPress versie 5.8.1
    Huidig thema: Veen Child (versie )
    Huidige plugin: Yoast SEO (versie 17.2)
    PHP versie 7.4.14
    
    Foutdetails
    ===========
    Een fout van het type E_ERROR werd veroorzaakt op regelnummer 129 van het bestand /home/eetman1q/public_html/wp-content/plugins/wordpress-seo/src/memoizers/meta-tags-context-memoizer.php. Foutmelding: Uncaught TypeError: Argument 1 passed to Yoast\WP\SEO\Memoizers\Meta_Tags_Context_Memoizer::get() must be an instance of Yoast\WP\SEO\Models\Indexable, bool given, called in /home/eetman1q/public_html/wp-content/plugins/wordpress-seo/src/integrations/blocks/breadcrumbs-block.php on line 104 and defined in /home/eetman1q/public_html/wp-content/plugins/wordpress-seo/src/memoizers/meta-tags-context-memoizer.php:129
    Stack trace:
    #0 /home/eetman1q/public_html/wp-content/plugins/wordpress-seo/src/integrations/blocks/breadcrumbs-block.php(104): Yoast\WP\SEO\Memoizers\Meta_Tags_Context_Memoizer->get(false, 'Post_Type')
    #1 /home/eetman1q/public_html/wp-includes/class-wp-block.php(221): Yoast\WP\SEO\Integrations\Blocks\Breadcrumbs_Block->present(Array, '', Object(WP_Block))
    #2 /home/eetman1q/public_html/wp-includes/blocks.php(868): WP_Block->render()
    #3 /home/eetman1q/public_html/wp-includes/blocks.php(906): render_block(Array)
    #4 /home/eetman1q/public_html/wp-includes/class-wp-hook.php(303): do_blocks('
    Plugin Support Suwash Kunwar

    (@suascat_wp)

    @jdevreede

    We’re sorry for the continued trouble. To narrow down the cause and verify if this a bug, we would like to request you to perform a conflict check. Often, we see problems occur in combination with another plugin or theme. The fastest way to rule out any conflict, is to deactivate all non-Yoast plugins and switch to a standard theme like Twenty Twenty.

    Please test this on your development or staging site, if you have one. If not, we recommend using the Health Check & Troubleshooting plugin. This plugin has a troubleshooting mode, which does not affect normal visitors to your site.

    If you’re unfamiliar with checking for conflicts, we’d like to point you to a step-by-step guide that will walk you through the process: How to check for plugin conflicts

    Plugin Support Suwash Kunwar

    (@suascat_wp)

    Meantime, also please refer to this thread for some reference.

    Thread Starter jdevreede

    (@jdevreede)

    @suascat_wp

    Thanks for your help. I do not have a testing site, so I used the Health Check plugin you recommended.

    – it’s health check only mentioned a recommendation for AMP

    Then I tested editing a blogpost, these were te results

    – with all plugins switched off >>> there were no problems with the autosave
    – then with my Veen theme plugins switched on >>> no problems with the autosave
    – then with the Veen theme plugins AND Yoast switched on >>> the crash occured
    – switching Yoast of again solved it.

    So yes, it does seem some sort of conflict between the theme and Yoast

    Plugin Support Michael Tina

    (@mikes41720)

    Hi @jdevreede

    Thank you for the testing you’ve performed on this.

    We’ve identified this as a bug when the Yoast SEO breadcrumb block causes a fatal error on a post with an unregistered indexable.

    A bug report has already been created. We’ll be having a patch release of Yoast SEO v17.2.1 later today so that this issue will be addressed.

    Please be on the lookout for the plugin update and update when it is available, and let us know if this addresses the issue – https://yoast.com/help/how-can-i-update-my-free-plugin/

    Thread Starter jdevreede

    (@jdevreede)

    I finally was able to test the new version. It solved the problem!

    Thank you for the speedy response

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.