Support » Plugin: Yoast SEO » Yoast Plugin Broken (14.4-RC1)

  • Resolved ellenc3

    (@ellenc3)


    Hi there,

    One of my clients is currently running the 14.4-RC1 version of the Yoast SEO WordPress plugin on their multisite WordPress installation.

    There are two questions/issues here:

    One, that the 14.4-RC1 version of this module appears to have broken styling, rendering the functions of the plugin unusable.

    When you are trying to edit a blog post, the SEO, Readability and Social tabs are unusable/do not show as tabs on the ‘Edit Blog’ page. No recommendations can be seen. See screenshot: https://ibb.co/BjLySTG
    When viewing all posts, you are also not given the ‘Readability’ or ‘SEO’ score filters, alongside each blog post. https://ibb.co/3zhmVPt

    When visiting the ‘SEO’ tab generally, the styling is not clean and images associated with the plugin filling the screen.

    Is this an issue you have seen with the 14.4-RC1 version of the module before, where the plugin is effectively rendered unusable? Can you confirm if it is fixed in more up to date versions? It seems that this is an issue with the version when viewing this forum post, but please confirm: https://wordpress.org/support/topic/terrible-updates/

    My second question is that we are running this plugin on a multisite set up of WordPress. Can we still leverage the free version of the Yoast plug on each blog associated with the multisite set-up? Or do we need to purchase Yoast SEO Premium to have the plugin available to use on all?

    I look forward to your reply.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support devnihil

    (@devnihil)

    @ellenc3 The current release of Yoast SEO is 15.8 and we’re only able to offer support for the current release of Yoast SEO. If you’re experiencing an issue with Yoast SEO and it not appearing as expected on the edit page, we’d first recommend updating to the current version.

    Regarding Multisite setup and installation of the SEO Premium plugin, we have more information on this here: https://yoast.com/help/can-i-use-the-plugin-on-multiple-sites/

    Thread Starter ellenc3

    (@ellenc3)

    @devnihil can you confirm whether this broken styling/broken features is a known issue for the 14.4 version of the module, please? Upgrading is our next step, but I would like to confirm whether this was a known issue experienced on this specific version of the plugin, or whether there may be something else causing this… like the multisite set-up?

    Regarding the multisite set-up/Yoast SEO, please can you clarify if you have to have SEO premium for a multisite blog? Or can the free version of Yoast be utilised? This is not clear in the article linked.

    Thank you for your help.

    Plugin Support Michael Tina

    (@mikes41720)

    Hi,

    We can’t determine if it’s a known issue with that specific version of Yoast SEO for WordPress. If the Yoast SEO meta box or sidebar functionality doesn’t load as expected, it’s most likely a plugin or theme conflict — https://yoast.com/help/how-to-check-for-plugin-conflicts/

    However, in any case, we definitely would recommend updating to the latest version of Yoast SEO for WordPress v15.8 so you can receive the latest features, and so we can provide support if there are any issues or concerns.

    The free version of Yoast SEO for WordPress can be utilized on multisites.

    Do you mean to say you are asking if you can use Yoast SEO Premium on the root site and then use Yoast SEO free on one of the subsites? It would depend on your setup if you are network activating it or if you’ve installed it separately for each site.

    Plugin Support devnihil

    (@devnihil)

    We are going ahead and marking this issue as resolved due to inactivity. If you require any further assistance please create a new issue.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.