Support » Plugin: Yoast SEO » Yoast Plugin and Google Search Console sitemap submission

  • Resolved amandacorden

    (@amandacorden)


    Hello,

    I want to add the Sitemap which is generated with YOAST Plug-In into my Search Console.

    I keep getting “General HTTP error” ” We encountered an error while trying to access your Sitemap. Please ensure your Sitemap follows our guidelines and can be accessed at the location you provided and then resubmit.”

    I can open the Sitemap with my browser without any Errors.

    I have changed the theme to make sure that was not it.

    I have made sure the robots.txt file is correct.

    I resubmit it every 5 hours to no avail.

    In the old console it just says pending.

    This has not happened on any other site i have submitted to google search console.

    I have read and searched for answers in your forums and in support to no end and have not found resolution.

    Additionally, the sitemap has been successfully submitted to bing.
    But if I want it to upload to Google Search Console it says “Can’t found the Sitemap” its a typical http error?

    Can someone help?

Viewing 15 replies - 1 through 15 (of 19 total)
  • only place this part post-sitemap.xml
    and not the full url

    It’s a long shot, but in my case, this issue was caused because I had enabled the “Block fake Googlebots” feature of the All-in-One Wp Security plugin.

    Plugin Support Michael Tina

    (@mikes41720)

    Could you please provide the URL to your sitemap so we can check on this? Can you confirm you have Yoast SEO for WordPress v9.1 and the Sitemaps feature enabled? The sitemap should generate under /sitemap_index.xml.

    thecordenreport.com/sitemap_index.xml

    The site map comes up in url in all browsers.
    The site map has been indexed on bing
    The site map cannot be indexed on google
    Google says it is unable to bc of robots.txt file
    Nothing in the robots.txt file shows it shouldnt
    google bots crawl all pass it.

    Thanks.

    @wpguillaume Thanks, but I do not have that. I have antispam plug in. I am getting so frustrated bc i have checked everything. And i just want to know what the issue is lol. So thanks for helping.

    Plugin Support amboutwe

    (@amboutwe)

    Since Bing accepted the sitemaps, the sitemaps load in the browser, and there isn’t a robots.txt block, we believe the issue is with what Google Search Console received. Please provide a screenshot of the error you see in Google Search Console.

    Plugin Support devnihil

    (@devnihil)

    @amandacorden Are you currently using any other sitemap plugins? We reviewed your robots.txt file at http://thecordenreport.com/robots.txt and see that several additional sitemaps are specified in robots.txt:

    # XML Sitemap & Google News version 5.0.7 - https://status301.net/wordpress-plugins/xml-sitemap-feed/
    Sitemap: http://thecordenreport.com/sitemap.xml
    Sitemap: http://thecordenreport.com/sitemap-news.xml
    Sitemap: http://thecordenreport.com/sitemap_location.xml

    If you are using another sitemap plugin, can you please try disabling it, checking to ensure the above code is removed from robots.txt, and then resubmitting the sitemap_index.xml to Google Search Console?

    I only added those plugins after having the issue. So removing it I am not seeing how that would solve it. This is now going on for 2 weeks. I need resolution. Please help.

    Plugin Support amboutwe

    (@amboutwe)

    In this screenshot, the error says that Google cannot reach the robots.txt file. Using the URL at the top, the robots.txt URL returns an ERR_SSL_PROTOCOL_ERROR.

    If you have SSL, your webhost can help you setup SSL for your site.

    If you do not have SSL, please submit the sitemap to the same URL (including the correct http/https and www/non-www) format shown under Admin > Settings > General

    Thank you so much for your swift response. By submitting the same URL what do you mean? I should submit it back to google search console. If so I do this 2x a day. I do not have an SSL and have contacted my web host there is no SSL present.

    Plugin Support amboutwe

    (@amboutwe)

    The Google Search Console profile in the screenshot is

    https://www.thecordenreport.com/

    Google Search Console treats each URL variation as separate but related properties. If you do not have SSL setup, please remove the Google Search Console profiles that begin with https and add the http version of your domain.

    Google also treats www and non-www as separate but related properties. WordPress can be setup to use either option so the best option is to check your WordPress settings under Admin > Settings > General and copy the “Site Address (URL)” to add it to Google Search Console.

    • This reply was modified 10 months, 3 weeks ago by  amboutwe.

    Fixed this:

    At some point I’d deleted the Yoast entry in my .htaccess file.

    Added their entries and everything worked straight away:

    https://kb.yoast.com/kb/xml-sitemaps-apache/

    yes…
    i have this problem too!
    and i cant fix this problem…
    please help me!
    i cant add my pagetags in google webmaster tools
    farstunes.net

    Plugin Support amboutwe

    (@amboutwe)

    @newfarstunes505 If you have a similar issue, please open a new request. That way it’s easier to track issues and provide assistance. Thanks!

Viewing 15 replies - 1 through 15 (of 19 total)
  • You must be logged in to reply to this topic.