Support » Plugin: Yoast SEO » Yoast Not Working on Blog Posts

Viewing 15 replies - 1 through 15 (of 18 total)
  • I have tried deactivating the plugin and then reactivating it, but still no luck…

    I am having a similar problem. It works as normal on pages but doesn’t appear anywhere for blog posts.
    I have deactivated the plugin, rolled back to a previous version, deactivated all plugins etc and nothing has worked so far. I just cannot get the plugin working again.
    Really frustrating as I have replaced several plugins (xml sitemap, robots etc) with this one and now face having to deactivate this and set up several different plugins again as well as finding a way of transferring the SEO data for each post to a new SEO plugin…

    I am also having a problem with scheduling the blog posts that occurred at the same time. The edit link is there, but I cannot seem to click on it and change the scheduled time of the post – I don’t know if you are experiencing this problem as well?

    I haven’t tried scheduling blog posts so dont know.
    When I am looking at blog posts the only thing that shows that WP SEO is installed is the small colored circle indicating how good the SEO is – that’s it though. No menus to actually fill in the details or anything. When I click on “posts” to display all posts there are no columns anymore showing SEO although there is still the option in the drop sown menu to select which posts to show – those with good seo / bad seo / no seo etc.
    Just seems like the menus are for some reason missing for all blog posts….

    When I am adding a new blog post I see WordPress SEO by Yoast section underneath the posting area, however there is no longer anything underneath it to allow me to set the SEO. I have tried clicking on the title to expand the box by clicking on it, but nothing happens. I still see the colored circle in the upper right of the page, however it is grey as I cannot set the SEO.

    I have installed another plugin for the time being – All In One SEO Pack – which has allowed me to set the title and meta tags for new posts for the time being.

    I am hoping to find a way to get Yoast functioning properly again, as I have used that for all pages on my site and like how it indicates the level of the SEO…

    Yoast fixed this for me – really, really simple fix:
    WP SEO settings
    Titles and Meta
    Post types
    and uncheck “Hide” under WordPress SEO meta box

    Spent hours on this, he fixed in about 8 seconds 🙂
    Much appreciated Yoast!

    I tried that solution, but when I go to “Titles and Meta” under the SEO settings, I don’t see any options at all. There is no content, other than the right hand column with the support, “Spread the Word” and latest news boxes. The tabs at the top, “General”, “Home”, etc. don’t do anything either.

    Any ideas?

    I looked into that as well and “Hide” was not checked in that section. Tried re-saving the setting with “Hide” unchecked as well and not luck.

    Any other suggestions on how to resolve this issue?

    Thank you!

    Some of the phrasing is not what I would use, so I’m not sure if everyone has been using the general WordPress navigation tools.

    • When editing a blog entry, in the upper right corner is a “Screen Options” tab. You can select whether to hide the editing widgets. If the Yoast SEO widget is not visible, make it visible.
    • If only the SEO widget title is visible, move the mouse to the far right of the gray bar which has the widget title, and an arrow icon should appear which makes the widget expand.

    WordPress has a habit of only making some tools pop up when you hover over a part of the screen. I don’t know how it works on a touchscreen (where you can’t hover).

    Under the screen options tab Yoast is checked. Yoast appears under the content area for the blog entry, however when I click on the arrow to make it expand nothing happens – only the WordPress SEO by Yoast title appears.

    I am having the same issue as prospectfgi. The title area for the SEO plugin appears on the page but none of the boxes to enter text are there. It looks collapsed and if you click the expand arrow nothing happens.

    I am having the same issue. I can see the ‘WordPress SEO by Yoast’ on each page but clicking on it to expand it does nothing.
    I would be really grateful if somebody could help out as I have spent a really long time on this with no luck.
    Thanks very much.

    I am having the same issue. I can see the ‘WordPress SEO by Yoast’ on each page but clicking on it to expand it does nothing.
    I would be really grateful if somebody could help out as I have spent a really long time on this with no luck.
    Thanks very much.

    I am also having ‘this problem’ but I think it is a problem with 3.5, not Yoast SEO. I also can’t edit post permalinks, show the screen options tab when editing a post, add media or anything else. So the Yoast SEO plugin is not displaying because wordpress itself is having a problem.

    It is probably being covered on the 3.5 master list;

    It’s most probably a plugin or any jQuery stuff built into your theme. Check your plugins and themes for updates from the developers, and see the master list for known problems and fixes. A theme update from the developer fixed this issue for me.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Yoast Not Working on Blog Posts’ is closed to new replies.