Support » Plugin: Yoast SEO » Yoast Meta description box not showing

  • Resolved shabdbeej

    (@shabdbeej)


    After recent Yoast upadte, i dont see yoast box to change SEO title & meta description below post edit. Why this happened ? What should i do ? Please see screenshot -> https://prnt.sc/nmf803

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 17 total)
  • irado

    (@irado)

    Hi,

    I’m having the same issue, as numerous other people, and for quite some time now from I’d gather from previous posts, some going back to 4 months or more.
    Here’s my little findings:
    Disabling Classic editor (v1.5) always fixes the issue, regardless of your theme, or other plugins installed. But then who would want to work with Guttenberg? Especially for websites built with 4.9 or older WordPress versions, and pagemakers.
    Disabling Custom types didn’t fix anything.
    Disabling WPML Multilingual (v4.0) fixes the issue too, while maintaining Classic Editor activated. But then, I can byebye to my 4-language website.

    So it looks to me the issue is a little more complex than simply disabling this or that. And Yoast will have hard time to fix this, IF they ever bother looking into it.. IUntil they do, I’m not going to renew the several licences I have with them..

    Just for the sake of it, I did update WP to the latest version (v5.2) and everything’s a mess now (something to do with the Axiom updater).

    irado

    (@irado)

    A final note: as a workaround, you can temporarily disable Classic Editor, input your meta into Yoast and re-enable Classic. It works, albeit it’s a major drag but it works.

    edugarlao

    (@edugarlao)

    I have the same problem, I can not add either title or description, and it is an important issue to be able to continue working correctly SEO.

    Can you check please?

    EcoTechie

    (@seedsca)

    Same here, it looks like it may be after the WordPress 5.2 update…

    Switching the post from Classic Editor to Block makes it work again in our case.

    cosmicfaery

    (@cosmicfaery)

    I have the same issue and hope it will be fixed soon. I’ve also got WP 5.2 and classic editor.

    montagnana

    (@montagnana)

    Same issue with our site, same as the screenshot in OP. We dont have the classic editor plugin…we took the dive and just decided to not fight it and get used to Gutten. Hoping Yoast will push a fix soon for this, in the meantime I’ll just go through one by one turning off plugins to see which one is causing the fault.

    shabdbeej

    (@shabdbeej)

    Guys i have raised this query & i posted this on a forum (https://help.gulshankumar.net) too. Their admin guy checked and said – Please clear your browser cache, restart and check again. I followed this & voila ! all things back to normal again. Hope it work for others too.

    montagnana

    (@montagnana)

    That did not work for me Shabd.

    Yoast wrote this:

    Thanks for the email! We are not sure why a blank box is appearing. We suggest a conflict check. Sometimes strange behavior may be caused by a plugin or theme conflict. The fastest way to rule out conflicts is to deactivate all non-Yoast plugins and switch to a standard theme like Twenty Seventeen. We recommend using the Health Check & Troubleshooting plugin as it allows you to run a conflict check without affecting normal visitors to your site.

    If you are unfamiliar with checking for conflicts, we wrote a step by step guide that will walk you through the process. You can find it here: How to Check For Plugin Conflicts

    Can you please inform us of the results?

    montagnana

    (@montagnana)

    Should note, the box is fine in regular WordPress pages, but the box is empty in WooCommerce pages

    EcoTechie

    (@seedsca)

    So there are a couple of scenarios here:

    Some are fixed by clearing the cache, including the browser’s.
    Others are fixed by using Gutenberg/blocks instead of Classic editor.
    Others still only have this problem with WooCommerce pages…

    Plugin Support marcanor

    (@marcanor)

    Please check if the Gutenberg plugin is installed and activated on your sites. There is a known conflict with the Gutenberg plugin that can break the Yoast Metabox.

    Please note that as of WordPress version 5.0 or higher, Gutenberg is already the default editor, so it’s not needed on your sites and can be deleted.

    If your sites are not running Gutenberg or if the issue persists, that sounds like a plugin or theme conflict. Can you try and gather as much information for us as possible? Please perform the following:
    1. Make sure the issue doesn’t persist when Yoast SEO is disabled.
    2. Check for conflicts.
    3. Check for JavaScript errors with your console.
    If you find any JavaScript errors related to Yoast SEO or if there is a conflict with a plugin or a theme, you can create a new GitHub issue for our developers. Please report the issue to a third party developer as well.
    If you didn’t find any conflicts or errors, we think the issue is specific to your site. We’d need to investigate further but are unable to do so on these forums. You can purchase Yoast SEO Premium and receive our Premium email support and we can help you further.

    Alicia

    (@amduffy)

    The meta description and title box is displaying normally in Gutenberg editor, but broken in classic editor – which a lot of people still use.

    Plugin Support Pcosta88

    (@pcosta88)

    Hi,

    Using WordPress v5.2, Classic Editor v1.5 , WooCommerce v3.6.3, and Yoast SEO v11.2.1, we can confirm on Posts and Product Yoast loads as expected.

    Post: See image – https://pasteboard.co/IfJbkXh.png

    Products: See image – https://pasteboard.co/IfJbEcX.png

    We can also confirm it works with Classic Editor disabled and just using the Gutenberg blocks, too.

    We ask that you please verify the following:

    1. Can you confirm you are using the most recent Yoast SEO, v11.2.1?

    2. Are all your non-Yoast plugins and themes also updated?

    3. Can you confirm you are using WordPress 5.2? You can check by clicking on the W in the top left and selecting About. If you need to update, please check with your host provider. Please know that if you are using an older version of WordPress Core you may experience unexpected behavior with Yoast. This guide explains more: https://yoast.com/why-we-dont-support-old-wordpress-versions/.

    If all are updated, we ask that you perform a conflict check. This guide explains more: https://kb.yoast.com/kb/how-to-check-for-plugin-conflicts/

    Looks like it’s fixed in the newest version:

    11.2.1

    Release Date: May 16th, 2019

    Bugfixes:

    Fixes a bug where the metabox would be empty on WordPress versions below 5.0.
    Fixes a bug where the metabox would be empty when both the classic editor plugin as well as the Gutenberg plugin were installed.

    hi,

    so updating only Yoast to the latest version (11.2.1) didn’t do the trick. however, after updating WPML to the last version (4.0.7), it finally worked. but i didn’t upgrade WP and we’re still running a 4.9.x version.

    hope this helps.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Yoast Meta description box not showing’ is closed to new replies.