Support » Plugin: Yoast SEO » Yoast makes updating pages take forever

  • Resolved sjoerd89

    (@sjoerd89)


    Hi there,

    updating pages on website take about 40seconds to a full minute. This only happens when Yoast is activated. When i de-activate the plugin the updating of pages works great and fast. I tried all the other plugins and none of them caused this and also a standard theme wouldn’t do a thing only de-activating Yoast will resolve this.

    Any ideas?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Hi
    I will join you and say that i have the same problem, this happened after 2 last updates sometimes the post is updated with some error.
    Because my site is a paid membership site i suspect that my posts are forwarded somewhere that is why it takes so long, hope i am wrong. 😀
    P.s. After i will make my forums free to view thinking to buy the pro version.

    Same for me, yoast seo is slowing that my site heavily since latest versions :/

    Make sure you clear all transients.

    Also make sure you’re running PHP 5.6 or higher, as older versions no longer work well with Yoast SEO, or WordPress in general. 5.2/5.3 are not secure; 5.4 is end of life and a ‘dog’ compared to 5.6.

    Might not help, but worth a look.

    Personally, i use wp sweep to clear transients every day + php 7.0

    Used wp sweep to clean everything,
    have a php 5.6.30 so that should work fine.

    Any other ideas because now everytime i have to update something i have to de-activate Yoast.

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    That sounds like a plugin or theme conflict. Can you try and gather as much information for us? Please perform the following:

    1. Check for conflicts.
    3. Check for JavaScript errors with your console.

    If you find any JavaScript errors related to Yoast SEO or if there is a conflict with a plugin or a theme, you can create a new issue on GitHub for our developers. Please report the issue to a third party developer as well.

    If you didn’t find any conflicts or errors, we think the issue is specific to your site. We’d need to investigate further but are unable to do so on these forums. You can purchase Yoast SEO Premium and receive our Premium email support and we can help you further.

    I love how always one of the only options is to just stop all plugins. On a live site this is often not possible. I have de-activated a lot of the plugins and tested if the problem was still there but it only occured when yoast was active and stopped when i de-activated yoast.

    Besides that there are no JS errors in my console.

    Same problem with last version, updating or inserting a new post take near 5 minutes.

    There is no errors in PHP logs, or javascript console errors.

    Thank you

    • This reply was modified 1 year, 11 months ago by  DannetStudio.
    Plugin Support amboutwe

    (@amboutwe)

    @sjoerd89 We understand that disabling plugins and switching theme is not an easy thing to do on a live site. Since you’re not seeing an error and we know that Yoast SEO works in our multiple test environments, we know the issue is specific to your setup. Unfortunately, you are in the best position to help us track down the issue so our development team can reproduce the issue and research solutions.

    That being said, we added a new feature in v5.0. Does disabling the new feature reduce the time it takes to update a post or page?

    How To Enable or Disable the Link Count feature?

    Hi Amboutwe,

    over the weekend i played around with a lot of the plugins and still could not find a issue between one of my plugins. Now for the “enabling or disabling the link counter” this will lower my updating time greatly! I think it is back to normal speed when disabling this.

    I am sorry if i acted a bit frustrated, i know you and your team spend a lot of time helping out the people on the forums (even the free plugin users) and i am really thankfull for that.

    Sjoerd

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Yoast makes updating pages take forever’ is closed to new replies.