Support » Plugin: Yoast SEO » Yoast Logo Schema not working For Google

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Pcosta88

    (@pcosta88)

    Hi,

    To clarify, Google is not indexing logos on this specific page: https://blowfishseo.com/? We ask as we are not sure which pages on your site have the issue.

    Thread Starter livingeasylivecom

    (@livingeasylivecom)

    I attached the graphic showing all pages logos are disappearing from all pages.

    Plugin Support Pcosta88

    (@pcosta88)

    Hi,

    We looked at the homepage https://blowfishseo.com/ and we can see the logo is: https://blowfishseo.com/wp-content/uploads/2019/09/blowfish-seo-logo-p-social.png. See image: https://pasteboard.co/IT8Lmoy.png.

    We then looked in Google and can see the log has been indexed and is appearing in a Google Image Search here.

    So Google is able to find and index the logo. In this manner, we are not sure why they are failing to show the logo as a rich snippet in the SERP pages or why Google is unable to identify it in the Logo section of your Google Search Console.

    We can only suggest the following actions as Google may need to re-crawl the site:

    1. Clear all your caching from your theme, plugin, server, CDN like CloudFlare or browser. If you are not sure how to clear caching from theme/plugin please speak to those authors. If you want to clear cache from the server, please speak to your host provider. To clear the cache from a browser use this guide: https://kb.yoast.com/kb/how-to-clear-my-browsers-cache/.

    2. Delete your sitemap in Google. Doing so will not hurt the SEO of the site. This guide explains more (scroll to the bottom): https://support.google.com/webmasters/answer/183669?hl=en.

    3. Submit the sitemap again. Be sure to submit only sitemap_index.xml and nothing else. This guide explains more: https://kb.yoast.com/kb/submit-sitemap-search-engines/.

    4. Monitor the results to see if the issue resolves.

    Thread Starter livingeasylivecom

    (@livingeasylivecom)

    Pcosta88

    Well done, I will implement these directives at some point over the next 24 Hours! I’ve been trying to figure out how to get them to reindex the whole site! Citations to you!!

    I will give it a few days and let you know how it works out!

    Plugin Support Pcosta88

    (@pcosta88)

    Hi,

    As the issue appears to be resolved we will close this in order to keep the overview. You’re always welcome to re-open this topic. Please read this post: https://wordpress.org/support/topic/read-this-before-your-post/ before opening a new request: https://wordpress.org/support/plugin/wordpress-seo/#new-post.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Yoast Logo Schema not working For Google’ is closed to new replies.